Bug 966937 - Reply use the default account to fill From:
Reply use the default account to fill From:
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
18
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-24 06:30 EDT by Nuno Dias
Modified: 2013-05-31 12:20 EDT (History)
3 users (show)

See Also:
Fixed In Version: evolution-3.8.2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-31 12:20:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nuno Dias 2013-05-24 06:30:29 EDT
Description of problem:
When replying to a mail, the From: is filled with the mail address of the default account instead of the mail of the account where the mail come from.

Version-Release number of selected component (if applicable):
evolution-3.6.4-3.fc18.x86_64


How reproducible:
Every time

Steps to Reproduce:
1. Create two accounts in evolution, one pop3 and the other imap, define the imap account as default.
2. Send a mail to the account (pop3), that is not the default account.
3. Select the mail received in the pop3 account and reply

Actual results:
The From: is filled with the mail from the default account

Expected results:
The From: Filled with the mail of the account where the mail come from.

Additional info:
Comment 1 Milan Crha 2013-05-31 12:20:42 EDT
Thanks for a bug report. I suggest to retest with evolution 3.8.x (it is part of to-be-released Fedora 19), because I have the same scenario as you, my POP3 messages reside in On This Computer/Inbox, and if I reply to a message which was received through POP3, then the From is chosen properly, with the POP3 account, while if I reply in an IMAP folder, it's chosen the IMAP account.

Note You need to log in before you can comment on or make changes to this bug.