Bug 967005 - Windows guest agent does not report version for some installed applications
Windows guest agent does not report version for some installed applications
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-guest-agent (Show other bugs)
3.2.0
Unspecified Unspecified
unspecified Severity medium
: ---
: 3.3.0
Assigned To: Vinzenz Feenstra [evilissimo]
Pavel Stehlik
virt
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-24 09:51 EDT by Jiri Belka
Modified: 2015-09-22 09 EDT (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-29 06:21:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jiri Belka 2013-05-24 09:51:44 EDT
Description of problem:

RHEV-Application Provisioning Tool never contains version, also Microsoft .NET Framework 4 Client Profile, although I can see version of these apps when they are selected in 'Programs and Features' window botton tab.

# vdsClient -s 0 getVmStats 1b4b8755-e40e-403f-a385-ad1a96c04058 | egrep "guestName|appsList"
        guestName = JB-W7-X86
        appsList = ['Microsoft .NET Framework 4 Client Profile', 'RHEV-Tools 3.2.8', 'RHEV-Serial 3.2.4', 'Microsoft .NET Framework 4 Client Profile', 'RHEV-Spice-Agent 3.2.5', 'RHEV-Agent 3.2.5', 'RHEV-SSO 3.2.4', 'RHEV-USB 3.2.3', 'RHEV-Balloon 3.2.4', 'RHEV-Application Provisioning Tool', 'Microsoft Visual C++ 2008 Redistributable - x86 9.0.30729.17', 'RHEV-Spice 3.2.3', 'RHEV-Block 3.2.4', 'RHEV-Network 3.2.4']

Version-Release number of selected component (if applicable):
3.2.8

How reproducible:
100%

Steps to Reproduce:
1. install GA
2. check versions of reported apps
3.

Actual results:
some apps do not have version number

Expected results:
include version number as well

Additional info:
Comment 1 Michal Skrivanek 2013-05-27 03:04:15 EDT
we're querying DisplayName. Can you doublecheck or attach the registry file?
Comment 2 Jiri Belka 2013-05-27 05:47:35 EDT
You are right, you use DisplayName and not using DisplayVersion. This is even more funny - RHEV-Spice-3.2.3 as DisplayName and 4.9.3 as DisplayVersion (this RHEV-Spice was installed from 3.2.5 iso). So what kind of evidence is version value in DisplayName?... Feel free to tell RHEV-APT owner to change DisplayName for this app.
Comment 3 Vinzenz Feenstra [evilissimo] 2013-05-27 07:35:03 EDT
Lev, what's the reason for the DisplayVersion strings not to correspond with the DisplayName?
Comment 4 Jiri Belka 2013-05-28 03:23:00 EDT
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\{99F19E86-12E5-4CE5-BD55-5542861743F4}]
"AuthorizedCDFPrefix"=""
"Comments"=""
"Contact"=""
"DisplayVersion"="4.9.3"
"HelpLink"=""
"HelpTelephone"=""
"InstallDate"="20130524"
"InstallLocation"="C:\\Program Files\\Redhat\\RHEV\\"
"InstallSource"="C:\\Users\\user\\AppData\\Local\\Temp\\{DDD9960C-2E37-4E35-8A0F-10EBCD402B93}\\"
"ModifyPath"=hex(2):4d,00,73,00,69,00,45,00,78,00,65,00,63,00,2e,00,65,00,78,\
  00,65,00,20,00,2f,00,49,00,7b,00,39,00,39,00,46,00,31,00,39,00,45,00,38,00,\
  36,00,2d,00,31,00,32,00,45,00,35,00,2d,00,34,00,43,00,45,00,35,00,2d,00,42,\
  00,44,00,35,00,35,00,2d,00,35,00,35,00,34,00,32,00,38,00,36,00,31,00,37,00,\
  34,00,33,00,46,00,34,00,7d,00,00,00
"Publisher"="Red Hat Inc."
"Readme"=""
"Size"=""
"EstimatedSize"=dword:0000029e
"UninstallString"=hex(2):4d,00,73,00,69,00,45,00,78,00,65,00,63,00,2e,00,65,00,\
  78,00,65,00,20,00,2f,00,49,00,7b,00,39,00,39,00,46,00,31,00,39,00,45,00,38,\
  00,36,00,2d,00,31,00,32,00,45,00,35,00,2d,00,34,00,43,00,45,00,35,00,2d,00,\
  42,00,44,00,35,00,35,00,2d,00,35,00,35,00,34,00,32,00,38,00,36,00,31,00,37,\
  00,34,00,33,00,46,00,34,00,7d,00,00,00
"URLInfoAbout"=""
"URLUpdateInfo"=""
"VersionMajor"=dword:00000004
"VersionMinor"=dword:00000009
"WindowsInstaller"=dword:00000001
"Version"=dword:04090003
"Language"=dword:00000409
"DisplayName"="RHEV-Application Provisioning Tool"
Comment 5 Lev Veyde 2013-05-28 04:44:00 EDT
(In reply to Vinzenz Feenstra from comment #3)
> Lev, what's the reason for the DisplayVersion strings not to correspond with
> the DisplayName?

DisplayName doesn't have to include any version information at all.
We include the version information as part of the package name for some packages only for the convenience of our customers, and to make it easier to identify if the correct version of tools is installed as the version displayed will always be based on the version of the RHEV.

For example for RHEV 3.2 all displayed package names (that include version information as part of the package name) will show 3.2.x version, where x is the build number of that specific component for that specific version of RHEV.

DisplayVersion on the other hand is the internal version of the package.
Comment 6 Lev Veyde 2013-05-28 04:56:30 EDT
(In reply to Jiri Belka from comment #2)
> You are right, you use DisplayName and not using DisplayVersion. This is
> even more funny - RHEV-Spice-3.2.3 as DisplayName and 4.9.3 as
> DisplayVersion (this RHEV-Spice was installed from 3.2.5 iso). So what kind
> of evidence is version value in DisplayName?... Feel free to tell RHEV-APT
> owner to change DisplayName for this app.

As already explained the version in the DisplayName will always be based on the version of the RHEV. So Windows Guest Tools ISO supplied with RHEV 3.2 will always have version of 3.2.x and all tools installed from it will display version of 3.2.y (where y is package specific for each tool) in it's name as seen in Add/Remove Programs etc.

If requested I can modify APT to work in the same way as well.
Comment 7 Vinzenz Feenstra [evilissimo] 2013-05-29 06:21:06 EDT
So according comments #5 and #6 this is wanted.

If we want the DisplayVersion value also to be reported that would be a new feature and has to be requested as such including changes to the guest agent, vdsm, engine backend and the UI

Note You need to log in before you can comment on or make changes to this bug.