Bug 967021 - [abrt] tracker-0.16.1-1.fc19: g_mutex_get_impl: Process /usr/libexec/tracker-extract was killed by signal 11 (SIGSEGV)
[abrt] tracker-0.16.1-1.fc19: g_mutex_get_impl: Process /usr/libexec/tracker-...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: tracker (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Igor Gnatenko
Fedora Extras Quality Assurance
abrt_hash:1f59206331bc6d4e0d27885b1e7...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-24 10:21 EDT by Hans de Goede
Modified: 2014-07-27 03:10 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-07-27 03:10:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (69.76 KB, text/plain)
2013-05-24 10:21 EDT, Hans de Goede
no flags Details
File: cgroup (139 bytes, text/plain)
2013-05-24 10:21 EDT, Hans de Goede
no flags Details
File: core_backtrace (2.60 KB, text/plain)
2013-05-24 10:22 EDT, Hans de Goede
no flags Details
File: dso_list (14.43 KB, text/plain)
2013-05-24 10:22 EDT, Hans de Goede
no flags Details
File: environ (1.13 KB, text/plain)
2013-05-24 10:22 EDT, Hans de Goede
no flags Details
File: limits (1.29 KB, text/plain)
2013-05-24 10:22 EDT, Hans de Goede
no flags Details
File: maps (70.63 KB, text/plain)
2013-05-24 10:22 EDT, Hans de Goede
no flags Details
File: open_fds (16.14 KB, text/plain)
2013-05-24 10:22 EDT, Hans de Goede
no flags Details
File: proc_pid_status (934 bytes, text/plain)
2013-05-24 10:22 EDT, Hans de Goede
no flags Details
File: var_log_messages (8.90 KB, text/plain)
2013-05-24 10:22 EDT, Hans de Goede
no flags Details

  None (edit)
Description Hans de Goede 2013-05-24 10:21:49 EDT
Description of problem:
Just logging in to a gnome3 session triggers this, it likely does not like one of my files.

Version-Release number of selected component:
tracker-0.16.1-1.fc19

Additional info:
reporter:       libreport-2.1.4
backtrace_rating: 4
cmdline:        /usr/libexec/tracker-extract
crash_function: g_mutex_get_impl
executable:     /usr/libexec/tracker-extract
kernel:         3.9.3-301.fc19.x86_64
runlevel:       N 5
uid:            500

Truncated backtrace:
Thread no. 1 (10 frames)
 #0 g_mutex_get_impl at gthread-posix.c:121
 #1 g_mutex_lock at gthread-posix.c:210
 #2 bin_element_is_sink at gstbin.c:1674
 #3 filter_next at gstiterator.c:480
 #4 gst_iterator_next at gstiterator.c:357
 #5 gst_iterator_fold at gstiterator.c:611
 #6 gst_bin_query at gstbin.c:3827
 #7 gst_element_query_duration at gstutils.c:2186
 #8 discoverer_collect at gstdiscoverer.c:1161
 #9 gst_discoverer_discover_uri at gstdiscoverer.c:1755

Potential duplicate: bug 828777
Comment 1 Hans de Goede 2013-05-24 10:21:54 EDT
Created attachment 752669 [details]
File: backtrace
Comment 2 Hans de Goede 2013-05-24 10:21:58 EDT
Created attachment 752670 [details]
File: cgroup
Comment 3 Hans de Goede 2013-05-24 10:22:02 EDT
Created attachment 752671 [details]
File: core_backtrace
Comment 4 Hans de Goede 2013-05-24 10:22:05 EDT
Created attachment 752672 [details]
File: dso_list
Comment 5 Hans de Goede 2013-05-24 10:22:09 EDT
Created attachment 752673 [details]
File: environ
Comment 6 Hans de Goede 2013-05-24 10:22:12 EDT
Created attachment 752674 [details]
File: limits
Comment 7 Hans de Goede 2013-05-24 10:22:16 EDT
Created attachment 752675 [details]
File: maps
Comment 8 Hans de Goede 2013-05-24 10:22:19 EDT
Created attachment 752676 [details]
File: open_fds
Comment 9 Hans de Goede 2013-05-24 10:22:22 EDT
Created attachment 752677 [details]
File: proc_pid_status
Comment 10 Hans de Goede 2013-05-24 10:22:26 EDT
Created attachment 752678 [details]
File: var_log_messages
Comment 11 Ankur Sinha (FranciscoD) 2013-05-28 23:35:18 EDT
Happened on my system just now. Abrt doesn't upload traces since the bug is already filed.
Comment 12 kokos 2013-09-30 18:37:45 EDT
This problem occurrs every time right after logging in to Gnome/Cinnamon

reporter:       libreport-2.1.7
backtrace_rating: 4
cmdline:        /usr/libexec/tracker-extract
crash_function: g_mutex_get_impl
executable:     /usr/libexec/tracker-extract
kernel:         3.10.11-200.fc19.i686
package:        tracker-0.16.2-1.fc19
reason:         Process /usr/libexec/tracker-extract was killed by signal 11 (SIGSEGV)
runlevel:       N 5
type:           CCpp
uid:            1000
Comment 13 Fedora Admin XMLRPC Client 2014-07-26 13:11:01 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 14 Fedora Admin XMLRPC Client 2014-07-27 02:32:56 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 15 Igor Gnatenko 2014-07-27 03:10:31 EDT
Hi,

thank you for this bug. Now we have in repos 1.0.2 so I think you can't reproduce this bug. If you can - please re-open!

Note You need to log in before you can comment on or make changes to this bug.