Bug 967094 - DeviceTreeError: duplicate uuids in device tree
DeviceTreeError: duplicate uuids in device tree
Status: CLOSED DUPLICATE of bug 969655
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:f14aa321cd7ab878b661f3158ae...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-24 12:55 EDT by Clyde E. Kunkel
Modified: 2014-12-08 17:21 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-12-08 17:21:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda.log (33.34 KB, text/plain)
2013-05-24 12:55 EDT, Clyde E. Kunkel
no flags Details
File: backtrace (498 bytes, text/plain)
2013-05-24 12:55 EDT, Clyde E. Kunkel
no flags Details
File: environ (760 bytes, text/plain)
2013-05-24 12:55 EDT, Clyde E. Kunkel
no flags Details
File: ifcfg.log (573 bytes, text/plain)
2013-05-24 12:55 EDT, Clyde E. Kunkel
no flags Details
File: lsblk_output (12.51 KB, text/plain)
2013-05-24 12:55 EDT, Clyde E. Kunkel
no flags Details
File: nmcli_dev_list (3.47 KB, text/plain)
2013-05-24 12:55 EDT, Clyde E. Kunkel
no flags Details
File: packaging.log (522.29 KB, text/plain)
2013-05-24 12:56 EDT, Clyde E. Kunkel
no flags Details
File: program.log (321.51 KB, text/plain)
2013-05-24 12:56 EDT, Clyde E. Kunkel
no flags Details
File: syslog (127.27 KB, text/plain)
2013-05-24 12:56 EDT, Clyde E. Kunkel
no flags Details
File: anaconda-tb (2.40 MB, application/octet-stream)
2013-05-24 12:56 EDT, Clyde E. Kunkel
no flags Details
File: storage.log (1.06 MB, application/octet-stream)
2013-05-24 12:56 EDT, Clyde E. Kunkel
no flags Details

  None (edit)
Description Clyde E. Kunkel 2013-05-24 12:55:35 EDT
Description of problem:
Installing to a previously used LV, forgot to select no bootloader, reset custom storage, clicked done to go back to disk selection, (yellow error checking storage configuration at bottom, expected this), clicked Full disk summary and bootloader, toggled to no bootloader.  System froze, went to get coffee, came back and found this error.
The following was filed automatically by anaconda:
anaconda 19.30-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 2083, in devices
    raise DeviceTreeError("duplicate uuids in device tree")
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 454, in devices
    devices = self.devicetree.devices
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/storage.py", line 771, in on_back_clicked
    disk not in self.storage.devices:
DeviceTreeError: duplicate uuids in device tree

Version-Release number of selected component:
anaconda-19.30-1

Additional info:
reporter:       libreport-2.1.4
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:UUID=afbcf488-11c6-4c3c-8c51-f8ef83d1920a selinux=0 BOOT_IMAGE=vmlinuz 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.9.2-301.fc19.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        19-Beta

Truncated backtrace:
Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/storage.py", line 771, in on_back_clicked
    disk not in self.storage.devices:
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 454, in devices
    devices = self.devicetree.devices
  File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 2083, in devices
    raise DeviceTreeError("duplicate uuids in device tree")
DeviceTreeError: duplicate uuids in device tree
Comment 1 Clyde E. Kunkel 2013-05-24 12:55:40 EDT
Created attachment 752787 [details]
File: anaconda.log
Comment 2 Clyde E. Kunkel 2013-05-24 12:55:43 EDT
Created attachment 752788 [details]
File: backtrace
Comment 3 Clyde E. Kunkel 2013-05-24 12:55:47 EDT
Created attachment 752789 [details]
File: environ
Comment 4 Clyde E. Kunkel 2013-05-24 12:55:51 EDT
Created attachment 752790 [details]
File: ifcfg.log
Comment 5 Clyde E. Kunkel 2013-05-24 12:55:54 EDT
Created attachment 752791 [details]
File: lsblk_output
Comment 6 Clyde E. Kunkel 2013-05-24 12:55:59 EDT
Created attachment 752792 [details]
File: nmcli_dev_list
Comment 7 Clyde E. Kunkel 2013-05-24 12:56:04 EDT
Created attachment 752793 [details]
File: packaging.log
Comment 8 Clyde E. Kunkel 2013-05-24 12:56:11 EDT
Created attachment 752794 [details]
File: program.log
Comment 9 Clyde E. Kunkel 2013-05-24 12:56:15 EDT
Created attachment 752795 [details]
File: syslog
Comment 10 Clyde E. Kunkel 2013-05-24 12:56:24 EDT
Created attachment 752796 [details]
File: anaconda-tb
Comment 11 Clyde E. Kunkel 2013-05-24 12:56:30 EDT
Created attachment 752797 [details]
File: storage.log
Comment 12 Reartes Guillermo 2013-05-29 18:57:11 EDT
Description of problem:
i was custom partitioning (lvm partition scheme) and trying to reproduce other bug, but
i got all mount points deleted by accidentally pressing esc on lost focus, so i stared again
but this time i got a yellow banner telling me that it failed to add device (or something similar).
Ok, let's rescan to clear al errors... i tought, i rescanned, it went to installation destination but
it was hyper-small, press done to redo custom partitioning but crash...

Version-Release number of selected component:
anaconda-19.30-1

Additional info:
reporter:       libreport-2.1.4
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2019-Beta\x20x86_64 quiet BOOT_IMAGE=vmlinuz 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.9.2-301.fc19.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        19-Beta

Truncated backtrace:
Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/storage.py", line 771, in on_back_clicked
    disk not in self.storage.devices:
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 454, in devices
    devices = self.devicetree.devices
  File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 2083, in devices
    raise DeviceTreeError("duplicate uuids in device tree")
DeviceTreeError: duplicate uuids in device tree
Comment 13 Reartes Guillermo 2013-05-31 11:09:07 EDT
Description of problem:
I tried to redo custom partitioning this time with 'standard partition' scheme,
because i had issues with the previos try (btrfs scheme).

i selected 3 disks, intended to create:

* /boot, swap and / as ext4 on vda
* /home as btrfs mirror

i was unable to complete the / as ext4 on vda with btrfs scheme, i got
the yellow banner and issues reconfiguring the device and such.
the mount point cannot be deleted, so i went back to the main hub,
strangely the begin install button was unlocked (but i knew that it was not ok).

I tried to redo it changing the scheme to standard partition but anaconda crashed.

Version-Release number of selected component:
anaconda-19.30-1

Additional info:
reporter:       libreport-2.1.4
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2019-Beta\x20x86_64 quiet BOOT_IMAGE=vmlinuz 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.9.2-301.fc19.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        19-Beta

Truncated backtrace:
Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/storage.py", line 771, in on_back_clicked
    disk not in self.storage.devices:
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 454, in devices
    devices = self.devicetree.devices
  File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 2083, in devices
    raise DeviceTreeError("duplicate uuids in device tree")
DeviceTreeError: duplicate uuids in device tree
Comment 14 Nick Harvey 2013-06-05 14:39:05 EDT
Description of problem:
partitioning disks during install

Version-Release number of selected component:
anaconda-19.30-1

Additional info:
reporter:       libreport-2.1.4
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2019-Beta\x20x86_64 quiet BOOT_IMAGE=vmlinuz 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.9.2-301.fc19.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        19-Beta

Truncated backtrace:
Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/storage.py", line 771, in on_back_clicked
    disk not in self.storage.devices:
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 454, in devices
    devices = self.devicetree.devices
  File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 2083, in devices
    raise DeviceTreeError("duplicate uuids in device tree")
DeviceTreeError: duplicate uuids in device tree
Comment 15 David Shea 2014-12-08 17:21:03 EST
Is this issue reproducable with F21?

*** This bug has been marked as a duplicate of bug 969655 ***

Note You need to log in before you can comment on or make changes to this bug.