Bug 967155 - SELinux is preventing /usr/sbin/abrtd from 'read' accesses on the directory abrt.
SELinux is preventing /usr/sbin/abrtd from 'read' accesses on the directory a...
Status: CLOSED DUPLICATE of bug 946919
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:87c7c302e067c0c7e3fa3f56078...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-24 21:38 EDT by Dan Mashal
Modified: 2013-05-28 02:57 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-28 02:57:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Mashal 2013-05-24 21:38:17 EDT
Description of problem:
SELinux is preventing /usr/sbin/abrtd from 'read' accesses on the directory abrt.

*****  Plugin catchall (100. confidence) suggests  ***************************

If you believe that abrtd should be allowed read access on the abrt directory by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep abrtd /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:abrt_t:s0-s0:c0.c1023
Target Context                system_u:object_r:initrc_tmp_t:s0
Target Objects                abrt [ dir ]
Source                        abrtd
Source Path                   /usr/sbin/abrtd
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           abrt-2.1.2-2.fc18.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.11.1-96.fc18.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 3.9.2-200.fc18.x86_64 #1 SMP Mon
                              May 13 13:59:47 UTC 2013 x86_64 x86_64
Alert Count                   1
First Seen                    2013-05-23 19:18:03 PDT
Last Seen                     2013-05-23 19:18:03 PDT
Local ID                      5db5d007-0763-4c14-9c45-c16f5fa45b1b

Raw Audit Messages
type=AVC msg=audit(1369361883.638:22): avc:  denied  { read } for  pid=487 comm="abrtd" name="abrt" dev="sda1" ino=5505114 scontext=system_u:system_r:abrt_t:s0-s0:c0.c1023 tcontext=system_u:object_r:initrc_tmp_t:s0 tclass=dir


type=SYSCALL msg=audit(1369361883.638:22): arch=x86_64 syscall=inotify_add_watch success=no exit=EACCES a0=6 a1=20d7350 a2=d80 a3=7fff392cdb00 items=0 ppid=1 pid=487 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 ses=4294967295 tty=(none) comm=abrtd exe=/usr/sbin/abrtd subj=system_u:system_r:abrt_t:s0-s0:c0.c1023 key=(null)

Hash: abrtd,abrt_t,initrc_tmp_t,dir,read

Additional info:
reporter:       libreport-2.1.4
hashmarkername: setroubleshoot
kernel:         3.9.3-301.fc19.x86_64
type:           libreport

Potential duplicate: bug 946919
Comment 1 Dan Mashal 2013-05-24 21:40:02 EDT
This happened after fedup 18 -> 19
Comment 2 Miroslav Grepl 2013-05-28 02:57:07 EDT

*** This bug has been marked as a duplicate of bug 946919 ***

Note You need to log in before you can comment on or make changes to this bug.