Bug 967167 - SELinux is preventing /usr/bin/clamscan from 'getattr' accesses on the chr_file /dev/kvm.
SELinux is preventing /usr/bin/clamscan from 'getattr' accesses on the chr_fi...
Status: CLOSED DUPLICATE of bug 967166
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:cd05d3e58f1ba37818376196655...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-25 03:04 EDT by Grosswiler Roger
Modified: 2013-05-27 06:15 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-27 06:15:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Grosswiler Roger 2013-05-25 03:04:38 EDT
Description of problem:
SELinux is preventing /usr/bin/clamscan from 'getattr' accesses on the chr_file /dev/kvm.

*****  Plugin catchall (100. confidence) suggests  ***************************

If sie denken, dass es clamscan standardmässig erlaubt sein sollte, getattr Zugriff auf kvm chr_file zu erhalten.
Then sie sollten dies als Fehler melden.
Um diesen Zugriff zu erlauben, können Sie ein lokales Richtlinien-Modul erstellen.
Do
zugriff jetzt erlauben, indem Sie die nachfolgenden Befehle ausführen:
# grep clamscan /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:antivirus_t:s0-s0:c0.c1023
Target Context                system_u:object_r:kvm_device_t:s0
Target Objects                /dev/kvm [ chr_file ]
Source                        clamscan
Source Path                   /usr/bin/clamscan
Port                          <Unbekannt>
Host                          (removed)
Source RPM Packages           clamav-0.97.8-1.fc19.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.12.1-44.fc19.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 3.9.3-301.fc19.x86_64 #1 SMP Mon
                              May 20 12:50:56 UTC 2013 x86_64 x86_64
Alert Count                   13
First Seen                    2013-05-13 06:50:08 CEST
Last Seen                     2013-05-25 06:58:20 CEST
Local ID                      d46fa03e-3114-425f-9e08-da29d7b9058f

Raw Audit Messages
type=AVC msg=audit(1369457900.848:24530): avc:  denied  { getattr } for  pid=23901 comm="clamscan" path="/dev/kvm" dev="devtmpfs" ino=6957 scontext=system_u:system_r:antivirus_t:s0-s0:c0.c1023 tcontext=system_u:object_r:kvm_device_t:s0 tclass=chr_file


type=SYSCALL msg=audit(1369457900.848:24530): arch=x86_64 syscall=lstat success=no exit=EACCES a0=6cc4b0 a1=7fff1f06d170 a2=7fff1f06d170 a3=3 items=0 ppid=23899 pid=23901 auid=0 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 ses=13 tty=(none) comm=clamscan exe=/usr/bin/clamscan subj=system_u:system_r:antivirus_t:s0-s0:c0.c1023 key=(null)

Hash: clamscan,antivirus_t,kvm_device_t,chr_file,getattr

Additional info:
reporter:       libreport-2.1.4
hashmarkername: setroubleshoot
kernel:         3.9.3-301.fc19.x86_64
type:           libreport
Comment 1 Miroslav Grepl 2013-05-27 06:15:36 EDT

*** This bug has been marked as a duplicate of bug 967166 ***

Note You need to log in before you can comment on or make changes to this bug.