Bug 967316 - Something should Obsoletes + Provides printer-filters
Something should Obsoletes + Provides printer-filters
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: foomatic (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
: 983192 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-26 10:28 EDT by Hans de Goede
Modified: 2013-07-18 01:49 EDT (History)
3 users (show)

See Also:
Fixed In Version: foomatic-4.0.9-3.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-18 01:49:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hans de Goede 2013-05-26 10:28:41 EDT
Something should Obsoletes + Provides printer-filters, so that it will get removed on upgrade to Fedora-19, and foomatic seems a sensible choice for this.

How reproducible:
Upgrade from F-18 to F-19, then run:

[hans@shalem ~]$ sudo package-cleanup --orphans
Loaded plugins: auto-update-debuginfo, langpacks, refresh-packagekit
printer-filters-1.1-7.fc18.noarch
[hans@shalem ~]$


Given that the latest build of printer-filters in koji is printer-filters-1.1-7.fc18, some printing related package should add:

Obsoletes: printer-filters < printer-filters-1.1-8
Provides: printer-filters = printer-filters-1.1-8
Comment 1 Tim Waugh 2013-06-03 10:19:17 EDT
I was never very clear on why it was introduced in the first place, honestly.

Yes, probably foomatic is the easiest place to put this.  I want to say that automatic printer driver installation obsoletes it, but there isn't really a single package that embodies that feature.
Comment 2 Jiri Popelka 2013-06-04 03:53:56 EDT
printer-filters is just a metapackage which requires several other packages that we deprecated too. Simply removing printer-filters does not remove them so we should Obsolete & Provide them too.

These are the last builds of them in koji:
c2050-0.3b-7.fc19
c2070-0.99-10.fc19
cjet-0.8.9-12.fc18
lx-20030328-9.fc19
pbm2l2030-1.4-10.fc19
pbm2l7k-990321-11.fc19
Comment 3 Hans de Goede 2013-06-04 05:27:43 EDT
Hi,

(In reply to Jiri Popelka from comment #2)
> printer-filters is just a metapackage which requires several other packages
> that we deprecated too. Simply removing printer-filters does not remove them
> so we should Obsolete & Provide them too.
> 
> These are the last builds of them in koji:
> c2050-0.3b-7.fc19
> c2070-0.99-10.fc19
> cjet-0.8.9-12.fc18
> lx-20030328-9.fc19
> pbm2l2030-1.4-10.fc19
> pbm2l7k-990321-11.fc19

Not sure if that is such a good idea, unlike printer-filters, people may have
a printer configured using these and thus may be relying on them. Unless we
know the old versions will break anyways, I believe it is best to just leave these
around for manual cleanup.

Regards,

Hans
Comment 4 Jiri Popelka 2013-06-04 06:06:36 EDT
Fair enough.

--
Jiri
Comment 5 Jiri Popelka 2013-07-10 13:07:04 EDT
*** Bug 983192 has been marked as a duplicate of this bug. ***
Comment 6 Fedora Update System 2013-07-10 13:11:19 EDT
foomatic-4.0.9-3.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/foomatic-4.0.9-3.fc19
Comment 7 Fedora Update System 2013-07-11 23:08:56 EDT
Package foomatic-4.0.9-3.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing foomatic-4.0.9-3.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-12821/foomatic-4.0.9-3.fc19
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2013-07-18 01:49:04 EDT
foomatic-4.0.9-3.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.