Bug 967344 - CONFIG_QUANTUM_OVS_BRIDGE_MAPPINGS= is not being used by packstack
CONFIG_QUANTUM_OVS_BRIDGE_MAPPINGS= is not being used by packstack
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-packstack (Show other bugs)
3.0
Unspecified Unspecified
high Severity high
: snapshot2
: 3.0
Assigned To: Ryan O'Hara
Ofer Blaut
:
: 968353 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-26 14:45 EDT by Ofer Blaut
Modified: 2016-04-26 11:55 EDT (History)
8 users (show)

See Also:
Fixed In Version: openstack-packstack-2013.1.1-0.8.dev601
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-11 14:53:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Remove bogus default value for CONFIG_QUANTUM_OVS_BRIDGE_MAPPINGS (1.18 KB, patch)
2013-05-29 12:38 EDT, Ryan O'Hara
no flags Details | Diff
Use CONFIG_QUANTUM_OVS_BRIDGE_MAPPINGS parameter (1.81 KB, patch)
2013-05-29 12:43 EDT, Ryan O'Hara
no flags Details | Diff
Use CONFIG_QUANTUM_OVS_BRIDGE_MAPPINGS parameter (1.92 KB, patch)
2013-05-30 14:18 EDT, Ryan O'Hara
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 30916 None None None Never

  None (edit)
Description Ofer Blaut 2013-05-26 14:45:17 EDT
Description of problem:

I have tried to configure quantum OVS, using packstack.

CONFIG_QUANTUM_OVS_BRIDGE_MAPPINGS= options is not being forward to plugin.ini files on L2 agents 

example below : 

# A comma separated list of VLAN ranges for the Quantum openvswitch
# plugin
CONFIG_QUANTUM_OVS_VLAN_RANGES=inter-vlan:201:203,ext-vlan:195:195


# A comma separated list of bridge mappings for the Quantum
# openvswitch plugin
CONFIG_QUANTUM_OVS_BRIDGE_MAPPINGS=inter-vlan:br-eth3


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.configure packstack answer file to use CONFIG_QUANTUM_OVS_BRIDGE_MAPPINGS=
2.run packstack
3.check /etc/quantum/plugins/openvswitch/ovs_quantum_plugin.ini to see file is not updated 

Actual results:


Expected results:


Additional info:
Comment 2 Ryan O'Hara 2013-05-29 12:38:29 EDT
Created attachment 754472 [details]
Remove bogus default value for CONFIG_QUANTUM_OVS_BRIDGE_MAPPINGS

The default value for CONFIG_QUANTUM_OVS_BRIDGE_MAPPINGS in packstack was actually a VLAN range, not a bridge mapping. This patch removes this default value.
Comment 3 Ryan O'Hara 2013-05-29 12:43:53 EDT
Created attachment 754474 [details]
Use CONFIG_QUANTUM_OVS_BRIDGE_MAPPINGS parameter

This patch takes the comma-separated string in CONFIG_QUANTUM_OVS_BRIDGE_MAPPINGS parameter, splits it by ',' and wraps each item in single quotes. This is necessary since the puppet module expects the ovs bridge_mappings to be an array. This patch also adds bridge_mappings to the quantum_ovs_agent.pp template, which uses the CONFIG_QUANTUM_OVS_BRIDGE_MAPPINGS parameter.
Comment 5 Ryan O'Hara 2013-05-30 14:18:50 EDT
Created attachment 754996 [details]
Use CONFIG_QUANTUM_OVS_BRIDGE_MAPPINGS parameter

Updated patch.
Comment 6 Ryan O'Hara 2013-05-30 14:33:27 EDT
*** Bug 968353 has been marked as a duplicate of this bug. ***
Comment 8 Ofer Blaut 2013-06-06 16:24:23 EDT
It is updated

openstack-packstack-2013.1.1-0.10.dev605.el6ost.noarch
Comment 9 errata-xmlrpc 2013-06-11 14:53:01 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0938.html

Note You need to log in before you can comment on or make changes to this bug.