Bug 967399 - [cups-driverd] Bad driver information file "/usr/share/cups/drv/cupsfilters.drv"!
[cups-driverd] Bad driver information file "/usr/share/cups/drv/cupsfilters.d...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: cups-filters (Show other bugs)
19
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-26 23:39 EDT by Trever Adams
Modified: 2013-06-07 23:43 EDT (History)
2 users (show)

See Also:
Fixed In Version: cups-filters-1.0.34-6.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-07 23:43:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Trever Adams 2013-05-26 23:39:31 EDT
Description of problem:
I do not know what is causing this, but I can no longer print as my computer no longer sees advertised printers. Avahi tools show the appropriate entries, but cups doesn't. This all started when I upgraded server and client to F19. (I don't print much. Printing from Windows to the CUPS server works.)

Version-Release number of selected component (if applicable):

cups-1.6.2-7.fc19.x86_64
cups-filesystem-1.6.2-7.fc19.noarch
cups-filters-1.0.34-1.fc19.x86_64
cups-filters-libs-1.0.34-1.fc19.x86_64
cups-libs-1.6.2-7.fc19.x86_64
ghostscript-cups-9.07-3.fc19.x86_64
gutenprint-cups-5.2.9-11.fc19.x86_64
python-cups-1.9.63-3.fc19.x86_64
Comment 1 Tim Waugh 2013-05-30 07:47:23 EDT
The 'Bad driver information file' message is due to this:

ppdc: Unable to find include file "<pcl.h>" on line 7 of /usr/share/cups/drv/cupsfilters.drv.

As for no longer seeing advertised printers: for the time being you can use cups-browsed on the client to detect network queues.
Comment 2 Trever Adams 2013-05-30 17:24:37 EDT
service  cups-browsed enable
service cups-browsed restart

Does the trick. I am not sure what changed so that this is required, but thank you very much, Tim!
Comment 3 Jiri Popelka 2013-06-01 10:37:47 EDT
Already fixed upstream
https://bugs.linuxfoundation.org/show_bug.cgi?id=1133
Comment 4 Trever Adams 2013-06-02 00:29:00 EDT
That fix may only fix one part of this bug. will it fix auto adding announced printers?
Comment 5 Jiri Popelka 2013-06-03 04:27:11 EDT
That change [1] fixes only the cupsfilters.drv problem.
Will you take a look at the other 'no longer seeing advertised printers' problem ?
Thanks

[1] https://koji.fedoraproject.org/koji/buildinfo?buildID=419262
Comment 6 Jiri Popelka 2013-06-03 04:50:28 EDT
(In reply to Jiri Popelka from comment #5)
> Will you take a look at the other 'no longer seeing advertised printers'
> problem ?

That was addressed to Tim. I overlooked who had written the comment.
Comment 7 Tim Waugh 2013-06-03 05:27:33 EDT
(In reply to Jiri Popelka from comment #5)
> Will you take a look at the other 'no longer seeing advertised printers'
> problem ?

cups-browsed is required for automatic network printing, currently.  I'm looking at what's needed to remove this requirement.
Comment 8 Fedora Update System 2013-06-03 05:55:33 EDT
cups-filters-1.0.34-4.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/cups-filters-1.0.34-4.fc19
Comment 9 Fedora Update System 2013-06-03 10:43:32 EDT
Package cups-filters-1.0.34-4.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing cups-filters-1.0.34-4.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-9926/cups-filters-1.0.34-4.fc19
then log in and leave karma (feedback).
Comment 10 Fedora Update System 2013-06-05 12:51:33 EDT
Package cups-filters-1.0.34-6.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing cups-filters-1.0.34-6.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-9926/cups-filters-1.0.34-6.fc19
then log in and leave karma (feedback).
Comment 11 Fedora Update System 2013-06-07 23:43:46 EDT
cups-filters-1.0.34-6.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.