Bug 967400 - [virtio-win][serial]win7-64 guest can not hotunplug/hotplug virtserialport during transfer data from host to guest
[virtio-win][serial]win7-64 guest can not hotunplug/hotplug virtserialport du...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virtio-win (Show other bugs)
6.5
Unspecified Unspecified
medium Severity high
: rc
: ---
Assigned To: Gal Hammer
Virtualization Bugs
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-26 23:42 EDT by lijin
Modified: 2014-01-01 11:41 EST (History)
9 users (show)

See Also:
Fixed In Version: virtio-win-prewhql-0.1.68
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-01 11:41:14 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description lijin 2013-05-26 23:42:06 EDT
Description of problem:
during transfer data from host to guest,hotplug the virtserialport and hotplug it agin,the qemu monitor prompt:"qemu-kvm: virtio-serial-bus: Unexpected port id 1 for device virtio-serial0.0" and "qemu-kvm: virtio-serial-bus: Guest failure in adding port 1 for device virtio-serial0.0"

Version-Release number of selected component (if applicable):
qemu-kvm-rhev-0.12.1.2-2.369.el6.x86_64
kernel-2.6.32-381.el6.x86_64
seabios-0.6.1.2-27.el6.x86_64
virtio-win-prewhql-62

How reproducible:
80%

Steps to Reproduce:
1.boot win7-64 guest with 2 virtserialport:
/usr/libexec/qemu-kvm -drive file=win7-64-serial-62.qcow2,if=none,cache=unsafe,media=disk,format=qcow2,id=drive-ide0-0-1 -device ide-drive,id=ide0-0-1,drive=drive-ide0-0-1,bootindex=0 -spice port=5900,disable-ticketing -vga qxl -global PIIX4_PM.disable_s3=0 -global PIIX4_PM.disable_s4=0 -usb -device usb-tablet -netdev tap,id=hostnet0 -device e1000,netdev=hostnet0,id=net0,mac=52:54:00:7f:f9:F6,bus=pci.0 -monitor stdio -chardev file,path=/root/console.log,id=serial1 -device isa-serial,chardev=serial1,id=s1 -device ich9-usb-uhci1,id=usb1,bus=pci.0 -cpu Penryn,hv_relaxed -M rhel6.4.0 -smp 2,maxcpus=2,cores=2,threads=1,sockets=1 -m 2G -bios /usr/share/seabios/bios.bin -enable-kvm -device virtio-serial-pci,id=virtio-serial0,max_ports=16 -chardev socket,path=/tmp/tt0,server,nowait,id=chardev0 -device virtserialport,chardev=chardev0,name=com.redhat.rhevm.vdsm,bus=virtio-serial0.0,id=port0 -chardev socket,path=/tmp/tt1,server,nowait,id=chardev1 -device virtserialport,chardev=chardev1,name=com.redhat.rhevm.vdsm1,bus=virtio-serial0.0,id=port1

2. Transferring data from host to guest via port0 in a loop
on the host # for ((;;)) ; do python serial-host-receive.py /tmp/tt0; done
on the guest #for ((;;)) ; do python VirtIOChannel_guest_send.py com.redhat.rhevm.vdsm;done

3. Transferring data form guest to host via port1 in a loop
on the guest # for ((;;)) ;do python VirtIOChannel_guest_reieve.py com.redhat.rhevm.vdsm1; done
on the host # for ((;;)) ;do python serial-host-send.py /tmp/tt1 ; done

4. Delete port1 and port2

5. Add port1 and port2 abd repeate step2,3,4,5

Actual results:
after step4 and step 5,port1 can be removed and add successfully;
but for port0,it shows as following:
(qemu) device_del port0
(qemu) qemu-kvm: virtio-serial-bus: Unexpected port id 1 for device virtio-serial0.0
(qemu) device_add virtserialport,chardev=chardev0,name=com.redhat.rhevm.vdsm,bus=virtio-serial0.0,id=port0
(qemu) qemu-kvm: virtio-serial-bus: Guest failure in adding port 1 for device virtio-serial0.0

Expected results:
both ports can be hotunplug and hotplug correctly.

Additional info:
hotunplug/hotplug can be successfully while virtserialport are not in use.
Comment 2 lijin 2013-06-06 01:23:38 EDT
same issue happened in build 64 when transfer data between host and guest
Comment 3 guo jiang 2013-06-07 01:11:46 EDT
win7-64(virtio-win-prewhql-64) hit the same issue when transfer data from host to guest.
package information:
   * Red Hat Enterprise Linux Server release 6.4 (Santiago)
   * kernel-2.6.32-358.el6.x86_64    
   * qemu-img-rhev-0.12.1.2-2.355.el6.x86_64
   * virtio-win-prewhql-0.1-64
   * spice-server-0.12.0-12.el6.x86_64
   * seabios-0.6.1.2-28.el6.x86_64
   * vgabios-0.6b-3.7.el6.noarch
   * sgabios-0-0.3.20110621svn.el6
Comment 4 lijin 2013-07-08 03:15:15 EDT
win7-64 guest hit the same issue in virtio-win-1.6.5-5
Comment 5 lijin 2013-07-08 03:39:03 EDT
(In reply to lijin from comment #4)
> win7-64 guest hit the same issue in virtio-win-1.6.5-5

the related package version information:
Red Hat Enterprise Linux Server release 7.0 Beta (Maipo)
kernel-3.10.0-0.rc7.64.el7.x86_64
qemu-kvm-1.5.1-2.el7.x86_64
virtio-win-1.6.5-5.el6_4.noarch
seabios-1.7.2.2-2.el7.x86_64
vgabios-0.6c-9.el7.noarch
sgabios-0.20110622svn-3.el7.x86_64
Comment 6 guo jiang 2013-07-08 22:01:49 EDT
win2012 guest hit the same issue in virtio-win-1.6.5-5, and related package version as comment #5.
Comment 7 guo jiang 2013-07-08 23:12:36 EDT
(In reply to guo jiang from comment #6)
> win2012 guest hit the same issue in virtio-win-1.6.5-5, and related package
> version as comment #5.
QE test in rhel7 host.
Comment 8 Gal Hammer 2013-08-08 07:42:01 EDT

*** This bug has been marked as a duplicate of bug 957328 ***
Comment 9 guo jiang 2013-09-04 01:51:53 EDT
Reproduce this issue on virtio-win-prewhql-67
Verify this issue on virtio-win-prewhql-68

other package version:
  kernel-2.6.32-416.el6.x86_64
  qemu-kvm-rhev-0.12.1.2-2.398.el6.x86_64
  virtio-win-prewhql-0.1.68
  spice-server-0.12.4-2.el6.x86_64  
  seabios-0.6.1.2-28.el6.x86_64
  vgabios-0.6b-3.7.el6.noarch

Step as comment #0

Actual result:
build 67:
(qemu)device_del port1 
(qemu) qemu-kvm: virtio-serial-bus: Unexpected port id 2 for device virtio-serial0.0
(qemu) device_add virtserialport,chardev=channel1,name=com.redhat.rhevm.vdsm1,bus=virtio-serial0.0,id=port1,nr=2
(qemu) qemu-kvm: virtio-serial-bus: Guest failure in adding port 2 for device virtio-serial0.0
build 68:
 could hot unplug and hot plug successfully.

Based on the above, this issue has been fixed already.
Comment 10 Mike Cao 2013-09-04 02:53:13 EDT
Move status to VERIFIED according to comment #9

Note You need to log in before you can comment on or make changes to this bug.