Bug 967497 - corosync start error messages are not logged
corosync start error messages are not logged
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: corosync (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity low
: rc
: ---
Assigned To: Jan Friesse
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-27 05:54 EDT by michal novacek
Modified: 2014-06-17 20:31 EDT (History)
2 users (show)

See Also:
Fixed In Version: corosync-2.3.1-1.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-13 06:27:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed patch - Output parse errors to syslog (1.31 KB, patch)
2013-06-20 06:36 EDT, Jan Friesse
no flags Details | Diff

  None (edit)
Description michal novacek 2013-05-27 05:54:43 EDT
Description of problem:
I have a corosync with existing but empty /etc/corosync/corosync.conf (which
happened unintentionally). Starting corosync using "systemctl start corosync"
gives you no error output -- it only says that it has failed [1]. Looking into
/var/log/messages [2] gives you the same non-specific information about why the
failure happened. To find the real problem you must run corosync on commandline
with -f to see that some error message [3]. 

I believe that error output should be visible in /var/log/messages


Version-Release number of selected component (if applicable):
corosync-2.3.0-3.el7.x86_64

How reproducible: always

Steps to Reproduce:
1. have empty /etc/corosync/corosync.conf
2. run "systemctl start corosync"

Actual results: no error messages 

Expected results: error message in /var/log/messages

Additional info:

[1]
# systemctl status corosync
corosync.service - Corosync Cluster Engine
   Loaded: loaded (/usr/lib/systemd/system/corosync.service; enabled)
   Active: failed (Result: exit-code) since Mon 2013-05-27 08:21:13 EDT

May 27 08:21:02 virt-062 systemd[1]: Starting Corosync Cluster Engine...
May 27 08:21:13 virt-062 corosync[958]: [62B blob data]
May 27 08:21:13 virt-062 systemd[1]: corosync.service: control process exited, code=exited status=1
May 27 08:21:13 virt-062 systemd[1]: Failed to start Corosync Cluster Engine.
May 27 08:21:13 virt-062 systemd[1]: MESSAGE=Unit corosync.service entered failed state.

[2]
# grep corosync /var/log/messages
...
May 27 05:34:04 virt-062 corosync[1602]: Starting Corosync Cluster Engine (corosync): [FAILED]#015[  OK  ]
May 27 05:34:04 virt-062 systemd[1]: corosync.service: control process exited, code=exited status=1
May 27 05:34:04 virt-062 systemd[1]: MESSAGE=Unit corosync.service entered failed state.11

[3]
# corosync -f 
notice  [MAIN  ] Corosync Cluster Engine ('2.3.0'): started and ready to provide service.
info    [MAIN  ] Corosync built-in features: dbus rdma systemd xmlconf snmp pie relro bindnow
error   [MAIN  ] Could not open /etc/corosync/authkey: No such file or directory
error   [MAIN  ] Corosync Cluster Engine exiting with status 8 at main.c:1166.
Comment 2 Jan Friesse 2013-06-20 06:36:03 EDT
Created attachment 763402 [details]
Proposed patch - Output parse errors to syslog
Comment 3 Jan Friesse 2013-06-20 06:38:11 EDT
Yes, I can agree. Systemd behaves differently then old init, where output to stderr was visible on terminal. Systemd hides everything and status display something from journald. Proposed patch should solve problem.
Comment 6 Ludek Smid 2014-06-13 06:27:27 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.