This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 967518 - Met "Reference ID" error when creating a jenkins server app if a jenkins server app already existed in domain
Met "Reference ID" error when creating a jenkins server app if a jenkins serv...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Online
Classification: Red Hat
Component: Pod (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Dan McPherson
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-27 06:39 EDT by joycezhang
Modified: 2015-05-14 20:17 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-11 00:11:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fixed on INT (35.19 KB, image/png)
2013-05-28 22:39 EDT, joycezhang
no flags Details

  None (edit)
Description joycezhang 2013-05-27 06:39:55 EDT
Description of problem:
If trying to create a jenkins server app in conditions of a jenkins server app existed, it would return error as below:

Unable to complete the requested operation due to: . Reference ID: 83d499f46ac34331f091c3d502cc15d5

Version-Release number of selected component (if applicable):
devenv_3277

How reproducible:
always

Steps to Reproduce:
1.Create an jenkins server app
2.Create another jenkins server app


Actual results:
Error is shown as pasted in description.

Expected results:
"Jenkins server app already existed" is shown instead of the Reference ID error.


Additional info:
Comment 1 Dan McPherson 2013-05-28 10:30:43 EDT
https://github.com/openshift/origin-server/pull/2650
Comment 3 joycezhang 2013-05-28 22:38:52 EDT
This issue is fixed on INT(devenv_3281), message "An application with jenkins-1.4 already exists within the domain. You can only have a single application with jenkins-1.4 within a domain."  is returned, please refer to attached screen shots.
Comment 4 joycezhang 2013-05-28 22:39:31 EDT
Created attachment 754117 [details]
fixed on INT

Note You need to log in before you can comment on or make changes to this bug.