Bug 967524 - Inconsistent prefix
Inconsistent prefix
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: mingw-filesystem (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Kai Tietz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-27 06:54 EDT by Miroslav Rezanina
Modified: 2015-09-23 21:40 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-28 01:29:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Miroslav Rezanina 2013-05-27 06:54:35 EDT
Description of problem:

When trying to configure qemu-kvm for cross-compile, can't properly setup prefix for commands. There currently two prefixes used:

- mingw64-
- x86_64-w64-mingw32-

mingw-filesystem seems to be only one using mingw64-. 

Expected results:

All parts of mingw enviroment should use same prefix.
Comment 2 Kai Tietz 2013-05-27 08:13:54 EDT
No, there are two prefixes.  One is mingw32- for 32.bit binary package, and the other is mingw64- for 64-bit one.  The host triplet used for cross-compilers are x86_64-w64-mingw32... for 64-bit, and i686-w64-mingw32... for 32-bit.

The source packages are using just mingw-.... prefix, as they are target-indepent.

I think this bug is invalid.
Comment 3 Miroslav Rezanina 2013-05-28 01:29:28 EDT
Ok, thanks for explaining...

Note You need to log in before you can comment on or make changes to this bug.