Bug 967700 - python-ceilometer depends on flask
python-ceilometer depends on flask
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-ceilometer (Show other bugs)
3.0
Unspecified Unspecified
unspecified Severity unspecified
: snapshot2
: 3.0
Assigned To: Pádraig Brady
Ami Jeain
:
Depends On: 967710
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-28 01:35 EDT by Attila Fazekas
Modified: 2016-01-04 09:42 EST (History)
5 users (show)

See Also:
Fixed In Version: openstack-ceilometer-2013.1-5.el6ost
Doc Type: Bug Fix
Doc Text:
The upstream configuration for ceilometer defaults enable the V1 API, which requires flask. Flask is not available in Red Hat OpenStack, without it installed though the ceilometer services would fail to start. As a result of the change to honor distribution specific configuration values the V1 API is now disabled and flask is no longer required. The ceilometer services are now able to start correctly.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-11 14:55:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Attila Fazekas 2013-05-28 01:35:08 EDT
flask is a hard dependency, and I was able to install ceilometer without that. 

cat /var/log/ceilometer/api.log 
2013-05-28 05:25:17 CRITICAL [ceilometer] No module named flask
Traceback (most recent call last):
  File "/usr/bin/ceilometer-api", line 37, in <module>
    root = app.VersionSelectorApplication()
  File "/usr/lib/python2.6/site-packages/ceilometer/api/app.py", line 85, in __init__
    from ceilometer.api.v1 import app as v1app
  File "/usr/lib/python2.6/site-packages/ceilometer/api/v1/app.py", line 20, in <module>
    import flask
ImportError: No module named flask
Comment 4 Pádraig Brady 2013-05-28 07:24:26 EDT
Ah this is probably because of bug #967710 as the config to disable the V1 API is ignored
Comment 7 errata-xmlrpc 2013-06-11 14:55:27 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0935.html

Note You need to log in before you can comment on or make changes to this bug.