Bug 967710 - ceilometer init script does not uses the dist configs
ceilometer init script does not uses the dist configs
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-ceilometer (Show other bugs)
3.0
Unspecified Unspecified
unspecified Severity unspecified
: snapshot2
: 3.0
Assigned To: Pádraig Brady
Ami Jeain
:
Depends On:
Blocks: 967700
  Show dependency treegraph
 
Reported: 2013-05-28 01:59 EDT by Attila Fazekas
Modified: 2016-01-04 09:47 EST (History)
5 users (show)

See Also:
Fixed In Version: openstack-ceilometer-2013.1-5.el6ost
Doc Type: Bug Fix
Doc Text:
Previously, the ceilometer initialization scripts explicitly referenced the default upstream configuration file. This meant that the configuration file containing distribution specific default settings was ignored. The explicit reference to the default upstream configuration file has been removed from the initialization scripts. Distribution specific configuration defaults are now honored to ensure that ceilometer is able to start correctly.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-11 14:55:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Attila Fazekas 2013-05-28 01:59:34 EDT
/usr/share/ceilometer/*-dist.conf are exist but not in use.


openstack-ceilometer-compute-2013.1-4.el6ost.noarch
openstack-ceilometer-common-2013.1-4.el6ost.noarch
openstack-ceilometer-collector-2013.1-4.el6ost.noarch
openstack-ceilometer-central-2013.1-4.el6ost.noarch
python-ceilometerclient-1.0.0-1.el6ost.noarch
python-ceilometer-2013.1-4.el6ost.noarch
openstack-ceilometer-api-2013.1-4.el6ost.noarch
Comment 3 Ami Jeain 2013-06-05 04:35:30 EDT
[root@new32 log(keystone_admin)]# ps aux |grep ceilo
166      17189  0.1  0.2 245016 22808 ?        S    14:52   0:00 /usr/bin/python /usr/bin/ceilometer-api --logfile /var/log/ceilometer/api.log
166      17219  0.1  0.3 275548 25336 ?        S    14:52   0:00 /usr/bin/python /usr/bin/ceilometer-agent-central --logfile /var/log/ceilometer/central.log
166      17234  0.1  0.3 290836 26304 ?        S    14:52   0:00 /usr/bin/python /usr/bin/ceilometer-agent-compute --logfile /var/log/ceilometer/compute.log
root     19537  0.0  0.0 103240   892 pts/0    S+   14:57   0:00 grep ceilo
[root@new32 log(keystone_admin)]# ps aux |grep nova
nova      2516  0.0  0.3 299620 29600 ?        S    May31   0:17 python /usr/bin/nova-novncproxy --web /usr/share/novnc/
nova     18764  0.0  0.0      0     0 ?        Z    May31   0:00 [python] <defunct>
nova     18765  0.0  0.0      0     0 ?        Z    May31   0:00 [python] <defunct>
nova     18766  0.0  0.0      0     0 ?        Z    May31   0:00 [python] <defunct>
nova     18767  0.0  0.0      0     0 ?        Z    May31   0:00 [python] <defunct>
nova     18768  0.0  0.0      0     0 ?        Z    May31   0:00 [python] <defunct>
nova     18769  0.0  0.0      0     0 ?        Z    May31   0:00 [python] <defunct>
nova     18771  0.0  0.0      0     0 ?        Z    May31   0:00 [python] <defunct>
root     19599  0.0  0.0 103240   892 pts/0    S+   14:57   0:00 grep nova
nova     27979  0.0  0.6 400388 53796 ?        S    May31   2:16 /usr/bin/python /usr/bin/nova-consoleauth --config-file /usr/share/nova/nova-dist.conf --config-file /etc/nova/nova.conf --logfile /var/log/nova/consoleauth.log
nova     28008  0.4  1.2 2009904 104088 ?      Sl   May31  24:06 /usr/bin/python /usr/bin/nova-compute --config-file /usr/share/nova/nova-dist.conf --config-file /etc/nova/nova.conf --logfile /var/log/nova/compute.log
nova     28251  0.4  1.5 474480 127712 ?       S    May31  24:50 /usr/bin/python /usr/bin/nova-conductor --config-file /usr/share/nova/nova-dist.conf --config-file /etc/nova/nova.conf --logfile /var/log/nova/conductor.log
nova     28284  0.0  0.7 406004 59420 ?        S    May31   2:52 /usr/bin/python /usr/bin/nova-scheduler --config-file /usr/share/nova/nova-dist.conf --config-file /etc/nova/nova.conf --logfile /var/log/nova/scheduler.log
nova     28327  0.0  0.6 400648 53856 ?        S    May31   2:23 /usr/bin/python /usr/bin/nova-cert --config-file /usr/share/nova/nova-dist.conf --config-file /etc/nova/nova.conf --logfile /var/log/nova/cert.log
nova     28381  0.4  0.7 301024 57476 ?        S    May31  27:14 /usr/bin/python /usr/bin/nova-api --config-file /usr/share/nova/nova-dist.conf --config-file /etc/nova/nova.conf --logfile /var/log/nova/api.log
nova     28397  0.0  0.4 282868 37808 ?        S    May31   0:00 /usr/bin/python /usr/bin/nova-api --config-file /usr/share/nova/nova-dist.conf --config-file /etc/nova/nova.conf --logfile /var/log/nova/api.log
nova     28398  0.0  1.1 441580 88480 ?        S    May31   0:15 /usr/bin/python /usr/bin/nova-api --config-file /usr/share/nova/nova-dist.conf --config-file /etc/nova/nova.conf --logfile /var/log/nova/api.log
nova     28399  0.0  1.1 441932 88704 ?        S    May31   0:12 /usr/bin/python /usr/bin/nova-api --config-file /usr/share/nova/nova-dist.conf --config-file /etc/nova/nova.conf --logfile /var/log/nova/api.log
nova     28400  0.0  1.0 441056 87968 ?        S    May31   0:12 /usr/bin/python /usr/bin/nova-api --config-file /usr/share/nova/nova-dist.conf --config-file /etc/nova/nova.conf --logfile /var/log/nova/api.log
nova     28401  0.0  1.1 441972 88884 ?        S    May31   0:12 /usr/bin/python /usr/bin/nova-api --config-file /usr/share/nova/nova-dist.conf --config-file /etc/nova/nova.conf --logfile /var/log/nova/api.log
nova     28402  0.0  1.1 441920 88760 ?        S    May31   0:12 /usr/bin/python /usr/bin/nova-api --config-file /usr/share/nova/nova-dist.conf --config-file /etc/nova/nova.conf --logfile /var/log/nova/api.log
nova     28403  0.0  1.0 417320 84388 ?        S    May31   0:06 /usr/bin/python /usr/bin/nova-api --config-file /usr/share/nova/nova-dist.conf --config-file /etc/nova/nova.conf --logfile /var/log/nova/api.log
nova     28404  0.0  1.0 417052 84212 ?        S    May31   0:06 /usr/bin/python /usr/bin/nova-api --config-file /usr/share/nova/nova-dist.conf --config-file /etc/nova/nova.conf --logfile /var/log/nova/api.log
nova     28405  0.0  1.0 417272 84444 ?        S    May31   0:08 /usr/bin/python /usr/bin/nova-api --config-file /usr/share/nova/nova-dist.conf --config-file /etc/nova/nova.conf --logfile /var/log/nova/api.log
nova     28406  0.0  0.6 301188 53972 ?        S    May31   0:00 /usr/bin/python /usr/bin/nova-api --config-file /usr/share/nova/nova-dist.conf --config-file /etc/nova/nova.conf --logfile /var/log/nova/api.log
Comment 5 errata-xmlrpc 2013-06-11 14:55:32 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0935.html

Note You need to log in before you can comment on or make changes to this bug.