Bug 967718 - python-ceilometerclient No handlers could be found for logger "ceilometerclient.common.http"
python-ceilometerclient No handlers could be found for logger "ceilometerclie...
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-ceilometerclient (Show other bugs)
3.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: 4.0
Assigned To: Eoghan Glynn
Kevin Whitney
: OtherQA
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-28 02:30 EDT by Attila Fazekas
Modified: 2016-04-26 11:26 EDT (History)
7 users (show)

See Also:
Fixed In Version: python-ceilometerclient-1.0.7-1.el6ost
Doc Type: Bug Fix
Doc Text:
Previously, an unrelated Metering client CLI logging message accompanied API errors: No handlers could be found for logger "ceilometerclient.common.http". This update resolves this by ensuring the basic logging config is applied on startup. Consequently, API error logs are more comprehensible.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-19 19:03:41 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1252775 None None None Never

  None (edit)
Description Attila Fazekas 2013-05-28 02:30:18 EDT
On 401 response the ceilometer client looking for a logger.

ceilometer --debug meter-list
INFO (connectionpool:203) Starting new HTTP connection (1): 10.34.69.214
DEBUG (connectionpool:295) "POST /v2.0/tokens HTTP/1.1" 200 3275
DEBUG (http:109) curl -i -X GET -H 'X-Auth-Token: d1569d09971f4f6ca0928b83dbbab1d8' -H 'Content-Type: application/json' -H 'Accept: application/json' -H 'User-Agent: python-ceilometerclient' http://10.34.69.214:8777/v1/meters
DEBUG (http:119) 
HTTP/1.0 401 Unauthorized
date: Tue, 28 May 2013 06:26:26 GMT
content-length: 276
content-type: text/plain; charset=UTF-8
www-authenticate: Keystone uri='https://127.0.0.1:35357'
server: WSGIServer/0.1 Python/2.6.6

401 Unauthorized

This server could not verify that you are authorized to access the document you requested. Either you supplied the wrong credentials (e.g., bad password), or your browser does not understand how to supply the credentials required.

 Authentication required  

WARNING (http:164) Request returned failure status.
Invalid OpenStack Identity credentials.

[root@new32 ceilometer(keystone_admin)]# ceilometer meter-list
No handlers could be found for logger "ceilometerclient.common.http"
Invalid OpenStack Identity credentials.
Comment 2 Eoghan Glynn 2013-11-19 11:07:54 EST
Fix proposed to master upstream:

   https://review.openstack.org/57271
Comment 3 Eoghan Glynn 2013-11-29 08:28:11 EST
Fix landed upstream:

  http://github.com/openstack/python-ceilometerclient/commit/22212491
Comment 4 Eoghan Glynn 2013-11-29 08:29:00 EST
Fix included in upstream python-ceilometerclient 1.0.7 release:

  https://pypi.python.org/pypi/python-ceilometerclient/1.0.7
Comment 9 errata-xmlrpc 2013-12-19 19:03:41 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1859.html

Note You need to log in before you can comment on or make changes to this bug.