Bug 967761 - Cannot query tasks on PostgreSQL due to: ERROR: column "names5_.text" must appear in the GROUP BY clause or be used in an aggregate function
Cannot query tasks on PostgreSQL due to: ERROR: column "names5_.text" must ap...
Status: CLOSED DUPLICATE of bug 955574
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: jBPM Core (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Kris Verlaenen
Jiri Svitak
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-28 05:26 EDT by Jiri Svitak
Modified: 2015-06-01 21:35 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-31 18:32:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
postgresql server log (81.86 KB, text/plain)
2013-05-28 05:26 EDT, Jiri Svitak
no flags Details

  None (edit)
Description Jiri Svitak 2013-05-28 05:26:55 EDT
Created attachment 753806 [details]
postgresql server log

Cannot query human tasks on PostgreSQL due to:

Caused by: org.postgresql.util.PSQLException: ERROR: column "names5_.text" must appear in the GROUP BY clause or be used in an aggregate function

The whole stacktrace is attached in server log file postgresql.txt.


To reproduce:
See the steps here: https://github.com/jsvitak/jbpm-6-examples/tree/master/rewards-basic
So just clone the repo, follow the steps in readme.md and configure EAP to use PostgreSQL datasource. Also change the hibernate.dialect in file
rewards-basic/src/main/resources/META-INF/persistence.xml
to org.hibernate.dialect.PostgreSQLDialect
The process starts correctly, but I was unable to list John's tasks. This operation works on MySQL without problems. It's possible that other problems may follow when approving tasks on PostgreSQL.

My environment:
PostgreSQL 9.1.9
Driver postgresql-9.1-902.jdbc4.jar
JBoss EAP 6.1.0.Beta1 (AS 7.2.0.Final-redhat-4)
Fedora 17
jBPM 6.0.0.Beta2 (have to use community deps as no product libraries are available in DR builds so far)
Comment 1 Maciej Swiderski 2013-05-28 06:02:01 EDT
Jiri, I believe this is a duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=955574 which has been already fixed on master and should be included in beta3.
Comment 2 Kris Verlaenen 2013-05-31 18:32:43 EDT

*** This bug has been marked as a duplicate of bug 955574 ***

Note You need to log in before you can comment on or make changes to this bug.