Bug 967800 - If ipv6.disable=1 on kernel cmdline, firewalld-cmd hangs, causing libvirtd to hang
If ipv6.disable=1 on kernel cmdline, firewalld-cmd hangs, causing libvirtd to...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: firewalld (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Thomas Woerner
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-28 07:10 EDT by Vojtěch Boček
Modified: 2013-10-02 21:15 EDT (History)
13 users (show)

See Also:
Fixed In Version: firewalld-0.3.5-1.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-02 02:47:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Logs from virt-manager (6.18 KB, text/plain)
2013-05-28 07:10 EDT, Vojtěch Boček
no flags Details

  None (edit)
Description Vojtěch Boček 2013-05-28 07:10:29 EDT
Created attachment 753860 [details]
Logs from virt-manager

Description of problem:
If "ipv6.disable=1" is specified in kernel cmdline, virt-manager is stuck at "Connecting..." and "virsh list" hangs with no output. This happens even when there is no network connection.

Version-Release number of selected component (if applicable):
Fedora 19 x86_64
libvirt-1.0.5.1-1.fc19.x86_64
virt-manager-0.10.0-0.5.gitde1695b2.fc19.noarch
qemu-1.4.2-2.fc19.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Add "ipv6.disable=1" to your kernel cmdline
2. Start "virt-manager" or "sudo virsh list"

Actual results:
virt-manager hangs at "connecting..." to qemu
virsh list hangs and does nothing.

Expected results:
virt-manager and virsh should work as usual.
Comment 1 Cole Robinson 2013-08-31 20:57:39 EDT
I can reproduce with libvirt git, the source seems to be that our first firewalld-cmd hangs. I can reproduce manually with:

sudo /bin/firewall-cmd --direct --passthrough ipv6 -n -L FORWARD
Comment 3 Fedora Update System 2013-09-30 08:35:54 EDT
firewalld-0.3.5-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/firewalld-0.3.5-1.fc20
Comment 4 Fedora Update System 2013-09-30 08:39:24 EDT
firewalld-0.3.5-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/firewalld-0.3.5-1.fc19
Comment 5 Fedora Update System 2013-09-30 22:02:07 EDT
Package firewalld-0.3.5-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing firewalld-0.3.5-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-17984/firewalld-0.3.5-1.fc20
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2013-10-02 02:47:56 EDT
firewalld-0.3.5-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Fedora Update System 2013-10-02 21:15:07 EDT
firewalld-0.3.5-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.