Bug 967932 - [abrt] mingw32-nsis-2.46-7.fc17: CResourceEditor::WriteRsrcSec: Process /usr/bin/makensis was killed by signal 11 (SIGSEGV)
[abrt] mingw32-nsis-2.46-7.fc17: CResourceEditor::WriteRsrcSec: Process /usr/...
Status: CLOSED DUPLICATE of bug 948074
Product: Fedora
Classification: Fedora
Component: mingw-nsis (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Richard W.M. Jones
Fedora Extras Quality Assurance
abrt_hash:765aaae6e329e561c04b10e1db9...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-28 11:17 EDT by Edward Rudd
Modified: 2013-05-29 18:32 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-29 18:32:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (84.85 KB, text/plain)
2013-05-28 11:17 EDT, Edward Rudd
no flags Details
File: cgroup (130 bytes, text/plain)
2013-05-28 11:17 EDT, Edward Rudd
no flags Details
File: core_backtrace (749 bytes, text/plain)
2013-05-28 11:17 EDT, Edward Rudd
no flags Details
File: dso_list (840 bytes, text/plain)
2013-05-28 11:17 EDT, Edward Rudd
no flags Details
File: environ (4.16 KB, text/plain)
2013-05-28 11:17 EDT, Edward Rudd
no flags Details
File: limits (1.29 KB, text/plain)
2013-05-28 11:17 EDT, Edward Rudd
no flags Details
File: maps (4.00 KB, text/plain)
2013-05-28 11:17 EDT, Edward Rudd
no flags Details
File: open_fds (160 bytes, text/plain)
2013-05-28 11:17 EDT, Edward Rudd
no flags Details
File: proc_pid_status (928 bytes, text/plain)
2013-05-28 11:17 EDT, Edward Rudd
no flags Details
File: smolt_data (3.42 KB, text/plain)
2013-05-28 11:17 EDT, Edward Rudd
no flags Details
File: var_log_messages (642 bytes, text/plain)
2013-05-28 11:18 EDT, Edward Rudd
no flags Details

  None (edit)
Description Edward Rudd 2013-05-28 11:17:20 EDT
Description of problem:
Just tried to build a nsis generated via Cmake's CPack (worked fne on Fedora 16)

Version-Release number of selected component:
mingw32-nsis-2.46-7.fc17

Additional info:
backtrace_rating: 4
cmdline:        makensis project.nsi
crash_function: CResourceEditor::WriteRsrcSec
executable:     /usr/bin/makensis
kernel:         3.7.9-104.fc17.x86_64
uid:            500
ureports_counter: 1

Truncated backtrace:
Thread no. 1 (4 frames)
 #0 CResourceEditor::WriteRsrcSec at Source/ResourceEditor.cpp:757
 #1 CResourceEditor::Save at Source/ResourceEditor.cpp:514
 #2 CEXEBuild::close_res_editor at Source/build.cpp:3379
 #3 CEXEBuild::write_output at Source/build.cpp:2449

Potential duplicate: bug 948074
Comment 1 Edward Rudd 2013-05-28 11:17:25 EDT
Created attachment 753943 [details]
File: backtrace
Comment 2 Edward Rudd 2013-05-28 11:17:28 EDT
Created attachment 753944 [details]
File: cgroup
Comment 3 Edward Rudd 2013-05-28 11:17:31 EDT
Created attachment 753945 [details]
File: core_backtrace
Comment 4 Edward Rudd 2013-05-28 11:17:35 EDT
Created attachment 753946 [details]
File: dso_list
Comment 5 Edward Rudd 2013-05-28 11:17:40 EDT
Created attachment 753947 [details]
File: environ
Comment 6 Edward Rudd 2013-05-28 11:17:43 EDT
Created attachment 753948 [details]
File: limits
Comment 7 Edward Rudd 2013-05-28 11:17:46 EDT
Created attachment 753949 [details]
File: maps
Comment 8 Edward Rudd 2013-05-28 11:17:51 EDT
Created attachment 753950 [details]
File: open_fds
Comment 9 Edward Rudd 2013-05-28 11:17:54 EDT
Created attachment 753951 [details]
File: proc_pid_status
Comment 10 Edward Rudd 2013-05-28 11:17:58 EDT
Created attachment 753952 [details]
File: smolt_data
Comment 11 Edward Rudd 2013-05-28 11:18:01 EDT
Created attachment 753953 [details]
File: var_log_messages
Comment 12 Kevin Kofler 2013-05-29 18:32:30 EDT
Uhm, yeah, that's the same crash. I'm sorry I dropped the ball on that, I'll have another look at fixing this ASAP.

*** This bug has been marked as a duplicate of bug 948074 ***

Note You need to log in before you can comment on or make changes to this bug.