Bug 967972 - Rebase Oz to latest upstream master to pull in fixes that enable serial console in libvirt XML
Rebase Oz to latest upstream master to pull in fixes that enable serial conso...
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: oz (Show other bugs)
3.0
Unspecified Unspecified
high Severity high
: rc
: 4.0
Assigned To: Ian McLeod
Udi
: Rebase
Depends On: 968234
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-28 13:09 EDT by Kashyap Chamarthy
Modified: 2016-04-26 13:12 EDT (History)
6 users (show)

See Also:
Fixed In Version: oz-0.11.0-2.el6
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Story Points: ---
Clone Of:
: 968234 (view as bug list)
Environment:
Last Closed: 2013-12-19 19:03:45 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kashyap Chamarthy 2013-05-28 13:09:20 EDT
These are the two commits that needs to be pulled in from Upstream master.

==========
commit 0dcb1aa5dafa97d5c7a2e894a4d8733437f46ed9
Author: Chris Lalancette <clalancette@gmail.com>
Date:   Wed May 22 20:18:05 2013 -0400

    Re-enable serial consoles on the libvirt XML.
    
    Signed-off-by: Chris Lalancette <clalancette@gmail.com>
==========
commit b21122458a931fd4835877f867c004fb4df6138d
Author: Chris Lalancette <clalancette@gmail.com>
Date:   Tue May 21 23:13:49 2013 -0400

    Add the serial console back to Fedora kickstarts.
    
    Signed-off-by: Chris Lalancette <clalancette@gmail.com>
==========

Notes:

The above patches enable serial console by default. Meaning once Oz install is finished, and the XML file is defined, one can directly connect to the guest using

   virsh start oz-guest1 --console
Comment 1 Kashyap Chamarthy 2013-05-28 13:15:48 EDT
Test detail:
------------


A script -- https://github.com/kashyapc/virt-scripts/blob/master/oz/oz-jeos.bash

    $ ./oz-jeos.bash 
    Usage: ./oz-create.bash <guest-name> <distro>
            'distro': f18, rhel6
            Examples: oz-jeos.bash f18-t1 f18       # create f18
                      oz-jeos.bash rhel6x-t1 rhel6  # create latest rhel6.x


Once install is done, define the libvirt XML for the guest. Assuming
you gave the name of it as 'rhel63-tbox1':

    virsh define rhel64-test1May_15_2013-15:29:50

List all the guests:

    virsh list --all

Start it:

    virsh start rhel64-test1

Connect to it via serial console:

    virsh console rhel64-test1


Oz notes
~~~~~~~~

Oz uses something called TDL (template descriptive language). 

An example TDL file:
------------------
    <template>
      <name>rhel64-tbox1</name>
      <os>
        <name>RHEL-6</name>
        <version>4</version>
        <arch>x86_64</arch>
        <install type='url'>
          <url>http://foo.bar.redhat.com/pub/rhel/released/RHEL-6/6.4/Server/x86_64/os</url>
        </install>
        <rootpw>testpwd</rootpw>
      </os>
      <description>RHEL 6.4 </description>
    </template>
------------------

If you want to manually try it, you can dump the above contents into
'rhel63.tdl' in the current directory, and do:

    $ oz-install ./rhel64.tdl

root password is defined in the TDL above as "testpwd"

NOTE: In the above tdl file, replace the <url> with path to an appropriate tree.

For more information, do:

   man oz-examples
Comment 4 Fabio Massimo Di Nitto 2013-12-09 08:28:33 EST
Too late for 4.0, target 4.0.z
Comment 9 Udi 2013-12-18 05:21:54 EST
tested on: oz-0.11.0-2.el6.noarch

Ran the commands:

./oz-jeos F19 f19
virsh define F19Dec_18_2013-12\:06\:33 
virsh list --all
virsh start F19
virsh console F19

... and log in with 'root' and a password 'redhat'
Comment 11 errata-xmlrpc 2013-12-19 19:03:45 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1859.html

Note You need to log in before you can comment on or make changes to this bug.