Bug 967988 - ldc-phobos not found in update or update-testing
ldc-phobos not found in update or update-testing
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: derelict (Show other bugs)
18
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: Christopher Meng
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-28 14:02 EDT by Bo Lan
Modified: 2014-02-06 03:46 EST (History)
5 users (show)

See Also:
Fixed In Version: ldc-2-49.20130623git9facd25.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-05 18:10:18 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bo Lan 2013-05-28 14:02:54 EDT
Description of problem:
When I run su -c 'yum update', it cannot be updated unless using --skip-broken. And the problem that it said is ldc-phobos not found.

Version-Release number of selected component (if applicable):
ldc-phobos-2-39.20130513git23df06a.fc18.x86_64

How reproducible:
Every time I run yum update since a couple weeks ago.

Steps to Reproduce:
1. Enable update and update testing repos.
2. su -c 'yum update'
3.

Actual results:
Error: Package: derelict-3-2.20120923gitb4f810c.fc18.x86_64 (@fedora)
           Requires: libphobos-ldc.so.60()(64bit)
           Removing: ldc-phobos-2-36.20130104git82a3216.fc18.x86_64 (@updates)
               libphobos-ldc.so.60()(64bit)
           Updated By: ldc-phobos-2-39.20130513git23df06a.fc18.x86_64 (updates-testing)
               Not found
           Available: ldc-phobos-2-30.20121003gitb8e62b8.fc18.x86_64 (fedora)
               libphobos-ldc.so.60()(64bit)
Error: Package: derelict-openAL-3-2.20120923gitb4f810c.fc18.x86_64 (@fedora)
           Requires: libphobos-ldc.so.60()(64bit)
           Removing: ldc-phobos-2-36.20130104git82a3216.fc18.x86_64 (@updates)
               libphobos-ldc.so.60()(64bit)
           Updated By: ldc-phobos-2-39.20130513git23df06a.fc18.x86_64 (updates-testing)
               Not found
           Available: ldc-phobos-2-30.20121003gitb8e62b8.fc18.x86_64 (fedora)
               libphobos-ldc.so.60()(64bit)
 You could try using --skip-broken to work around the problem
** Found 1 pre-existing rpmdb problem(s), 'yum check' output follows:
bash-4.2.45-1.fc18.x86_64 is a duplicate with bash-4.2.42-3.fc18.x86_64


Expected results:
The system updates successfully.

Additional info:
Comment 1 D. Charles Pyle 2013-06-06 06:35:42 EDT
The updates currently are present in updates-testing repository.  But, I get errors whenever I try to update, the same as happened before last round of updates containing these same files. Getting the following on Fedora 19-Beta in yumex:

Dependency Resolution Errors:

Package: tango-2-12.20120821git7b92443.fc19.x86_64 (@fedora)
    Requires: libphobos-ldc.so.60()(64bit)
    Removing: ldc-phobos-2-30.20121003gitb8e62b8.fc19.x86_64 (@fedora)
        libphobos-ldc.so.60()(64bit)
    Updated By: ldc-phobos-2-41.20130513git23df06a.fc19.x86_64 (updates-testing)
        Not found
Comment 2 D. Charles Pyle 2013-06-06 06:37:47 EDT
(In reply to D. Charles Pyle from comment #1)
> The updates currently are present in updates-testing repository.  But, I get
> errors whenever I try to update, the same as happened before last round of
> updates containing these same files. Getting the following on Fedora 19-Beta
> in yumex:
> 
> Dependency Resolution Errors:
> 
> Package: tango-2-12.20120821git7b92443.fc19.x86_64 (@fedora)
>     Requires: libphobos-ldc.so.60()(64bit)
>     Removing: ldc-phobos-2-30.20121003gitb8e62b8.fc19.x86_64 (@fedora)
>         libphobos-ldc.so.60()(64bit)
>     Updated By: ldc-phobos-2-41.20130513git23df06a.fc19.x86_64
> (updates-testing)
>         Not found

More extensive output from yumex:

04:29:27 : Connected to an network
04:29:27 : network interface em1 (r8169) is connected
04:29:27 : Starting yum child process
04:29:30 : YUM: Yum Version : 3.4.3
04:29:31 : YUM: Loaded plugins: auto-update-debuginfo, dellsysid, langpacks
04:29:31 : Setting Yum Option clean_requirements_on_remove = True
04:29:31 : Getting available updates
04:29:34 : 6 packages returned
04:29:34 : Getting available obsoletes
04:29:34 : 0 packages returned
04:29:34 : Adding Packages to view
04:29:34 : Added 6 Packages to view
04:29:39 : YUM: --> Running transaction check
04:29:39 : YUM: ---> Package ldc.x86_64 0:2-30.20121003gitb8e62b8.fc19 will be updated
04:29:39 : YUM: ---> Package ldc.x86_64 0:2-41.20130513git23df06a.fc19 will be an update
04:29:39 : YUM: ---> Package ldc-druntime.x86_64 0:2-30.20121003gitb8e62b8.fc19 will be updated
04:29:39 : YUM: ---> Package ldc-druntime.x86_64 0:2-41.20130513git23df06a.fc19 will be an update
04:29:39 : YUM: ---> Package ldc-druntime-devel.x86_64 0:2-30.20121003gitb8e62b8.fc19 will be updated
04:29:39 : YUM: ---> Package ldc-druntime-devel.x86_64 0:2-41.20130513git23df06a.fc19 will be an update
04:29:39 : YUM: ---> Package ldc-phobos.x86_64 0:2-30.20121003gitb8e62b8.fc19 will be updated
04:29:39 : YUM: --> Processing Dependency: libphobos-ldc.so.60()(64bit) for package: tango-2-12.20120821git7b92443.fc19.x86_64
04:29:39 : YUM: ---> Package ldc-phobos.x86_64 0:2-41.20130513git23df06a.fc19 will be an update
04:29:39 : YUM: ---> Package ldc-phobos-devel.x86_64 0:2-30.20121003gitb8e62b8.fc19 will be updated
04:29:39 : YUM: ---> Package ldc-phobos-devel.x86_64 0:2-41.20130513git23df06a.fc19 will be an update
04:29:39 : YUM: ---> Package ldc-phobos-geany-tags.noarch 0:2-30.20121003gitb8e62b8.fc19 will be updated
04:29:39 : YUM: ---> Package ldc-phobos-geany-tags.noarch 0:2-41.20130513git23df06a.fc19 will be an update
04:29:40 : YUM: --> Finished Dependency Resolution
04:29:40 : YUM: --> Finding unneeded leftover dependencies
04:29:44 : YUM: ---> Marking compat-libffi to be removed - no longer needed by ldc
04:29:44 : YUM: Found and removing 1 unneeded dependencies
04:29:44 : YUM: --> Running transaction check
04:29:44 : YUM: ---> Package compat-libffi.x86_64 0:3.0.10-3.fc19 will be erased
04:29:44 : YUM: ---> Package ldc-phobos.x86_64 0:2-30.20121003gitb8e62b8.fc19 will be updated
04:29:44 : YUM: --> Processing Dependency: libphobos-ldc.so.60()(64bit) for package: tango-2-12.20120821git7b92443.fc19.x86_64
04:29:44 : YUM: --> Finished Dependency Resolution
04:32:50 : ERROR: Dependency resolving completed with errors
04:32:50 : ERROR:   Package: tango-2-12.20120821git7b92443.fc19.x86_64 (@fedora)
    Requires: libphobos-ldc.so.60()(64bit)
    Removing: ldc-phobos-2-30.20121003gitb8e62b8.fc19.x86_64 (@fedora)
        libphobos-ldc.so.60()(64bit)
    Updated By: ldc-phobos-2-41.20130513git23df06a.fc19.x86_64 (updates-testing)
        Not found
Comment 3 MERCIER Jonathan 2013-06-06 16:42:36 EDT
Thanks for report i will wors on tomorrow

I apologize for delay i completely miss your report
Comment 4 D. Charles Pyle 2013-06-06 17:24:54 EDT
I was forced to remove tango in order to complete the update.  Look forward to the update that will allow them to coexist.  Thank you.
Comment 5 Timothy Ward 2013-06-18 19:27:01 EDT
Same when updating lastest ldc Packages on 32 bit system.

Failed with:

tango-2-11.20120821git7b92443.fc18.i686 requires libphobos-ldc.so.60 : Success - empty transaction

Which indicates that Tango needs updating. But produced the error message when
ldc packages update in progess. 

Removal of tango allowed the update to complete correctly.
Comment 6 Francis 2013-06-25 14:07:01 EDT
Same problem here.
Linux localhost.localdomain 3.9.6-200.fc18.x86_64 #1 SMP Thu Jun 13 18:56:55 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

adobe-linux-x86_64 
fedora/18/x86_64  
fedora-steam  
google-chrome  
livna
rpmfusion-free/18/x86_64  
rpmfusion-free-updates/18/x86_64 
rpmfusion-nonfree/18/x86_64  
rpmfusion-nonfree-updates/18/x86_64 
updates/18/x86_64   

Erreur : Paquet : derelict-openAL-3-2.20120923gitb4f810c.fc18.x86_64 (@fedora)
             Requiert : libphobos-ldc.so.60()(64bit)
             Suppression  : ldc-phobos-2-36.20130104git82a3216.fc18.x86_64 (@updates)
                 libphobos-ldc.so.60()(64bit)
             Mis à jour par : ldc-phobos-2-39.20130513git23df06a.fc18.x86_64 (updates)
                 Non trouvé
             Disponible : ldc-phobos-2-30.20121003gitb8e62b8.fc18.x86_64 (fedora)
                 libphobos-ldc.so.60()(64bit)
Erreur : Paquet : derelict-3-2.20120923gitb4f810c.fc18.x86_64 (@fedora)
             Requiert : libphobos-ldc.so.60()(64bit)
             Suppression  : ldc-phobos-2-36.20130104git82a3216.fc18.x86_64 (@updates)
                 libphobos-ldc.so.60()(64bit)
             Mis à jour par : ldc-phobos-2-39.20130513git23df06a.fc18.x86_64 (updates)
                 Non trouvé
             Disponible : ldc-phobos-2-30.20121003gitb8e62b8.fc18.x86_64 (fedora)
                 libphobos-ldc.so.60()(64bit)
Comment 7 Fedora Update System 2013-06-26 17:51:36 EDT
ldc-2-49.20130623git9facd25.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/ldc-2-49.20130623git9facd25.fc19
Comment 8 Fedora Update System 2013-06-27 11:48:05 EDT
Package ldc-2-49.20130623git9facd25.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing ldc-2-49.20130623git9facd25.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-11845/ldc-2-49.20130623git9facd25.fc19
then log in and leave karma (feedback).
Comment 9 Francis 2013-06-30 00:54:19 EDT
That's don't fix the libphobos problem for fc18.
ldc-phobos-2-39.20130513git23df06a.fc18.x86_64 is still not found.
Comment 10 Francis 2013-06-30 01:03:17 EDT
(In reply to Francis from comment #9)
> That's don't fix the libphobos problem for fc18.
> ldc-phobos-2-39.20130513git23df06a.fc18.x86_64 is still not found.

Fixed. That was weird.
Just remove ldc-phobos and then install.
Seems to be stucked on 2-36.
Comment 11 Fedora Update System 2013-07-12 21:57:55 EDT
ldc-2-49.20130623git9facd25.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Paul Stauffer 2013-08-01 09:33:38 EDT
The update may fix this for F19, but this is still broken in F18, which is the version this bug is filed against.

The problem is that derelict-3-2.20120923gitb4f810c.fc18.x86_64 and derelict-openAL-3-2.20120923gitb4f810c.fc18.x86_64 are explicitly requiring libphobos-ldc.so.60(), but the ldc-phobos-2-39.20130513git23df06a.fc18.x86_64 update now provides libphobos-ldc.so.62().  Presumably the derelict packages need to be updated to use the newer libphobos-ldc.so.

Reopening, and changing component to derelict.
Comment 13 MERCIER Jonathan 2013-08-01 15:50:56 EDT
oh sorry i will do it
Comment 14 Fedora Admin XMLRPC Client 2013-08-13 20:19:49 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 15 Fedora End Of Life 2013-12-21 10:32:02 EST
This message is a reminder that Fedora 18 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 18. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '18'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 18's end of life.

Thank you for reporting this issue and we are sorry that we may not be 
able to fix it before Fedora 18 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior to Fedora 18's end of life.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 16 Fedora End Of Life 2014-02-05 18:10:18 EST
Fedora 18 changed to end-of-life (EOL) status on 2014-01-14. Fedora 18 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.