Bug 967993 - Cinnamon crashes after upgrade to f19
Cinnamon crashes after upgrade to f19
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: cinnamon (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: leigh scott
Fedora Extras Quality Assurance
workaround: see comment 6
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-28 14:10 EDT by Kai Engert (:kaie)
Modified: 2013-07-01 02:05 EDT (History)
3 users (show)

See Also:
Fixed In Version: cinnamon-1.9.1-1.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-02 23:41:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kai Engert (:kaie) 2013-05-28 14:10:17 EDT
Today I upgraded my F18 system to early-F19, using the yum distro-sync approach.

I cannot login using Cinnamon, neither standard nor software rendering. Both result in a crash, and I'm asked to logout.

(Note that I had some trouble during the upgrade, because of an interrupted yum transaction, which required me to do system tweaking and cleanup. I'm not sure if it's related in any way to this crash. However, otherwise the system appears to work fine, and rpm -Va reports mostly sanity.)


I do have an abrt directory, so I can provide details of the crash. Let me know if you want a copy of the entire directory.

cinnamon-1.8.3-1.fc19

core_backtrace:

33a40c071dae844f7bf2ec8199ee340b5db30694 0x4eead g_logv /usr/lib64/libglib-2.0.so.0.3600.2 1837d04939f03b6aa855c3ea8b453caa60fd11c6
33a40c071dae844f7bf2ec8199ee340b5db30694 0x4f092 g_log /usr/lib64/libglib-2.0.so.0.3600.2 9c3b7408b09823ee507816e66eb9ebd2d6938139
d181e6bb4041b277f6d7b3e97f03cc71a7c849b4 0xa4734 g_settings_schema_get_value /usr/lib64/libgio-2.0.so.0.3600.2 65f3f4f6b581b54cee38e82252b32cf4ec6e89a6
d181e6bb4041b277f6d7b3e97f03cc71a7c849b4 0xa490d g_settings_schema_key_init /usr/lib64/libgio-2.0.so.0.3600.2 04d14b5c03ed025464bf6592a33762748b8685a6
d181e6bb4041b277f6d7b3e97f03cc71a7c849b4 0xa7c9b g_settings_get_value /usr/lib64/libgio-2.0.so.0.3600.2 22dc4dd3d2e5d6096777b8bff6bed6166ccef2bf
d181e6bb4041b277f6d7b3e97f03cc71a7c849b4 0xa88db g_settings_get_boolean /usr/lib64/libgio-2.0.so.0.3600.2 9a3f88366acb159f486c98c8858b211a1005afdc
d09081f1aeae71de020009a763ad1bd18f9139ae 0x5cfc ffi_call_unix64 /lib64/libffi.so.6 c4b6fd4def7199ae37097ad873efefe087480f37
d09081f1aeae71de020009a763ad1bd18f9139ae 0x562c ffi_call /lib64/libffi.so.6 c7b676db482fae39fc655262820259dba7db27de
ce1be33d4805a42e39120602969182f214073099 0x27b37 - /lib64/libgjs.so.0 2c08bd47d0d72aa53fcdeed80ff9ef64386277af
ce1be33d4805a42e39120602969182f214073099 0x29054 - /lib64/libgjs.so.0 251697dd22693aa4c863bab3d66f25c95c9d0600
18199ce6ea4f6cba47fe99bd7c1488ead59627b0 0xe2d99 js::Invoke(JSContext*, js::CallArgs const&, unsigned int) /lib64/libmozjs185.so.1.0 779d00547d5a154af624e7d0ff4087cedd7d67ff
18199ce6ea4f6cba47fe99bd7c1488ead59627b0 0xcc23a js::Interpret(JSContext*, JSStackFrame*, unsigned int, JSInterpMode) /lib64/libmozjs185.so.1.0 3b44bf60d29ed403e6030c93eae13bdb22486666
18199ce6ea4f6cba47fe99bd7c1488ead59627b0 0xe0a56 js::RunScript(JSContext*, JSScript*, JSStackFrame*) /lib64/libmozjs185.so.1.0 2743e9077e9c7273673951995c13e7addfdee566
18199ce6ea4f6cba47fe99bd7c1488ead59627b0 0xe18e8 js::Execute(JSContext*, JSObject*, JSScript*, JSStackFrame*, unsigned int, js::Value*) /lib64/libmozjs185.so.1.0 4f6d70c8d39092fe159895730605ba3db1913b8c
18199ce6ea4f6cba47fe99bd7c1488ead59627b0 0x4ca85 EvaluateUCScriptForPrincipalsCommon(JSContext*, JSObject*, JSPrincipals*, unsigned short const*, unsigned int, char const*, unsigned int, unsigned long*, JSVersion) /lib64/libmozjs185.so.1.0 363560fb7b4072d164c1110603e63bcf01295633
18199ce6ea4f6cba47fe99bd7c1488ead59627b0 0x4cc27 JS_EvaluateUCScriptForPrincipals /lib64/libmozjs185.so.1.0 57c4a316f73740100f48b3d88aaba9b0bd3fcc8f
18199ce6ea4f6cba47fe99bd7c1488ead59627b0 0x4cd31 JS_EvaluateScriptForPrincipals /lib64/libmozjs185.so.1.0 f72b933103b20d791763dba98a63e7c5513f69f9
18199ce6ea4f6cba47fe99bd7c1488ead59627b0 0x4ced2 JS_EvaluateScript /lib64/libmozjs185.so.1.0 432216b623976ebb6764ee22ad35566a315af659
ce1be33d4805a42e39120602969182f214073099 0x17e91 gjs_context_eval /lib64/libgjs.so.0 a485b7e50cdc3f54cfb2fce4064585acf436c640
e7b56c93603ea07764f4a58890dcea6ac6c6fd50 0x2c66f gnome_cinnamon_plugin_start /usr/lib64/cinnamon/libcinnamon.so 3704574c55d1f9b10326811d3d90b65628be9d4c
4c9f3a5433900474db9b9b0a778d4152f9b76302 0x28b50 meta_plugin_manager_initialize /lib64/libmuffin.so.0 c62641a6b72b1aa7af8e216833411f8e21145dbe
4c9f3a5433900474db9b9b0a778d4152f9b76302 0x261b7 meta_compositor_manage_screen /lib64/libmuffin.so.0 32f04bc38ebd7fd8e6db8149041dbfc70ce9dd5e
4c9f3a5433900474db9b9b0a778d4152f9b76302 0x38c84 meta_display_open /lib64/libmuffin.so.0 6264818cd1219d7f1930a1c9e8e174de33f37080
4c9f3a5433900474db9b9b0a778d4152f9b76302 0x462dd meta_run /lib64/libmuffin.so.0 45ddbcccb9a99039125fe5d17c0abc5511c3bd86
ac073403327081a5f921185e456cfb84ff6f1cdb 0x1a98 main /usr/bin/cinnamon 3458f32b338323a463947d856276b1f46f3bb154
Comment 1 Dan Mashal 2013-05-28 14:19:57 EDT
Please do the following:

yum update --enablerepo=updates-testing

If you get noting please paste output of:

rpm -qa |grep cinnamon
rpm -qa |grep nemo
rpm -qa |grep muffin
Comment 2 Kai Engert (:kaie) 2013-05-28 17:09:42 EDT
The crash is related to my ~/.config/dconf/user file, which is a preexisting file, from before the upgrade to F19.

I moved the filed away, and now I'm able to start cinnamon.
I wonder which settings I lost because of this...

Also, I installed debug information, so I can give you the full stack with variables:

#0  g_logv (log_domain=0x7fcdc31bda98 "GLib-GIO", log_level=G_LOG_LEVEL_ERROR, format=<optimized out>, args=args@entry=0x7fff764715e8) at gmessages.c:981
#1  0x00007fcdc1bba092 in g_log (log_domain=log_domain@entry=0x7fcdc31bda98 "GLib-GIO", log_level=log_level@entry=G_LOG_LEVEL_ERROR, format=format@entry=0x7fcdc31d8840 "Settings schema '%s' does not contain a key named '%s'")
    at gmessages.c:1010
#2  0x00007fcdc3179734 in g_settings_schema_get_value (schema=schema@entry=0x3dbe300, key=key@entry=0x3ea9360 "idle-dim-ac") at gsettingsschema.c:640
#3  0x00007fcdc317990d in g_settings_schema_key_init (key=key@entry=0x7fff76471750, schema=0x3dbe300, name=name@entry=0x3ea9360 "idle-dim-ac") at gsettingsschema.c:751
#4  0x00007fcdc317cc9b in g_settings_get_value (settings=0x3dce720, key=0x3ea9360 "idle-dim-ac") at gsettings.c:1079
#5  0x00007fcdc317d8db in g_settings_get_boolean (settings=<optimized out>, key=<optimized out>) at gsettings.c:1785
#6  0x00007fcdc0722cfc in ffi_call_unix64 () from /lib64/libffi.so.6
#7  0x00007fcdc072262c in ffi_call () from /lib64/libffi.so.6
#8  0x00007fcdc9e88b37 in gjs_invoke_c_function (context=context@entry=0x2199ce0, function=function@entry=0x257b520, obj=obj@entry=0x7fcd98ee7828, js_argc=js_argc@entry=1, js_argv=js_argv@entry=0x7fcda63fd648, 
    js_rval=js_rval@entry=0x7fff76471c78) at gi/function.c:893
#9  0x00007fcdc9e8a054 in function_call (context=0x2199ce0, js_argc=1, vp=0x7fcda63fd638) at gi/function.c:1202
#10 0x00007fcdc99cfd99 in CallJSNative (vp=0x7fcda63fd638, argc=1, native=<optimized out>, cx=0x2199ce0) at jscntxtinlines.h:701
#11 js::Invoke (cx=cx@entry=0x2199ce0, argsRef=..., flags=flags@entry=0) at jsinterp.cpp:696
#12 0x00007fcdc99b923a in js::Interpret (cx=cx@entry=0x2199ce0, entryFrame=entryFrame@entry=0x7fcda63fd048, inlineCallCount=10, inlineCallCount@entry=0, interpMode=interpMode@entry=JSINTERP_NORMAL) at jsinterp.cpp:4810
#13 0x00007fcdc99cda56 in js::RunScript (cx=cx@entry=0x2199ce0, script=script@entry=0x22d2aa0, fp=0x7fcda63fd048) at jsinterp.cpp:653
#14 0x00007fcdc99ce8e8 in js::Execute (cx=0x2199ce0, chain=<optimized out>, script=0x22d2aa0, prev=<optimized out>, flags=<optimized out>, result=0x7fff76472270) at jsinterp.cpp:1028
#15 0x00007fcdc9939a85 in EvaluateUCScriptForPrincipalsCommon (cx=0x2199ce0, obj=0x7fcdac203048, principals=<optimized out>, chars=<optimized out>, length=<optimized out>, filename=<optimized out>, lineno=lineno@entry=1, 
    rval=rval@entry=0x7fff76472270, compileVersion=JSVERSION_1_8) at jsapi.cpp:5031
#16 0x00007fcdc9939c27 in JS_EvaluateUCScriptForPrincipals (cx=<optimized out>, obj=<optimized out>, principals=<optimized out>, chars=<optimized out>, length=<optimized out>, filename=<optimized out>, lineno=1, 
    rval=0x7fff76472270) at jsapi.cpp:5058
#17 0x00007fcdc9939d31 in JS_EvaluateScriptForPrincipals (cx=0x2199ce0, obj=0x7fcdac203048, principals=principals@entry=0x0, bytes=<optimized out>, nbytes=nbytes@entry=54, filename=filename@entry=0x7fcdca3e9399 "<main>", 
    lineno=lineno@entry=1, rval=rval@entry=0x7fff76472270) at jsapi.cpp:5081
#18 0x00007fcdc9939ed2 in JS_EvaluateScript (cx=<optimized out>, obj=<optimized out>, bytes=<optimized out>, nbytes=nbytes@entry=54, filename=filename@entry=0x7fcdca3e9399 "<main>", lineno=lineno@entry=1, 
    rval=rval@entry=0x7fff76472270) at jsapi.cpp:5101
#19 0x00007fcdc9e78e91 in gjs_context_eval (js_context=0x7fcda0002370, script=<optimized out>, script@entry=0x7fcdca3e9400 "imports.ui.environment.init();imports.ui.main.start();", script_len=54, script_len@entry=-1, 
    filename=filename@entry=0x7fcdca3e9399 "<main>", exit_status_p=exit_status_p@entry=0x7fff764722c4, error=error@entry=0x7fff764722c8) at gjs/context.c:1013
#20 0x00007fcdca39a66f in gnome_cinnamon_plugin_start (plugin=<optimized out>) at cinnamon-plugin.c:193
#21 0x00007fcdca0ddb50 in meta_plugin_manager_initialize (plugin_mgr=0xb28100) at compositor/meta-plugin-manager.c:129
#22 0x00007fcdca0db1b7 in meta_compositor_manage_screen (compositor=<optimized out>, screen=0xb25200) at compositor/compositor.c:598
#23 0x00007fcdca0edc84 in enable_compositor (composite_windows=0, display=0x2227e10) at core/display.c:405
#24 meta_display_open () at core/display.c:849
#25 0x00007fcdca0fb2dd in meta_run () at core/main.c:567
#26 0x0000000000401a98 in main (argc=1, argv=0x7fff76472fb8) at main.c:324
Comment 3 Kai Engert (:kaie) 2013-05-28 17:11:15 EDT
> yum update --enablerepo=updates-testing

Nothing.


> If you get noting please paste output of:

[root@lapkaie ~]# rpm -qa |grep cinnamon
cinnamon-1.8.3-1.fc19.x86_64
cinnamon-debuginfo-1.8.3-1.fc19.x86_64
[root@lapkaie ~]# rpm -qa |grep nemo
nemo-1.8.2-1.fc19.x86_64
nemo-extensions-1.8.2-1.fc19.x86_64
[root@lapkaie ~]# rpm -qa |grep muffin
muffin-debuginfo-1.8.2-1.fc19.x86_64
muffin-1.8.2-1.fc19.x86_64
Comment 4 Dan Mashal 2013-05-28 17:19:20 EDT
(In reply to Kai Engert (:kaie) from comment #2)
> The crash is related to my ~/.config/dconf/user file, which is a preexisting
> file, from before the upgrade to F19.
> 
> I moved the filed away, and now I'm able to start cinnamon.
> I wonder which settings I lost because of this...
> 

Any settings stored in dconf (most user based customizations (themes, etc.)

> Also, I installed debug information, so I can give you the full stack with
> variables:

We know what broke cinnamon, but we appreciate the information and will see if linux mint upstream can do anything with it.

The root cause of this issue is Cinnamon code not being fully Gnome 3.8.x compatible.
Comment 5 Kai Engert (:kaie) 2013-05-28 17:25:42 EDT
Indeed, I lost a lot of configuration settings.

My deja-dup backup configuration had a lot of tweaking, it's unfortunate I lost it.
Comment 6 Kai Engert (:kaie) 2013-05-29 15:16:35 EDT
So to summarize:

- affected are users that had certain (at least the brightness) applets
  enabled in F18
- those users, when upgrading to F19, will be unable to login to
  cinnamon, because cinnamon crashes

We need a way for those people to recover, or even prepare.

My initial fix was to remove the dconf storage. But that file actually contained a lot of configuration, and I was unwilling to lose it.

I came up with the following solution, that allows to keep most of the old configuration, and will simply reset the list of enabled cinnamon applets.

The following commands can be executed from within a console window, even if the user is unable to start a graphical environment. The user should log in to the console using the affected user account, and execute the following commands:

$ export `dbus-launch`
  # comment: above command will run dbus and make environment variables
  #          available, that will allow the following commands to work.
$ dconf reset /org/cinnamon/enabled-applets
$ dconf reset /org/cinnamon/next-applet-id

The above commands should succeed without errors.
Afterwards, it should be possible to login with cinnamon.
Comment 7 leigh scott 2013-05-30 20:03:21 EDT
(In reply to Kai Engert (:kaie) from comment #6)
> So to summarize:
> 
> - affected are users that had certain (at least the brightness) applets
>   enabled in F18
> - those users, when upgrading to F19, will be unable to login to
>   cinnamon, because cinnamon crashes
> 
> We need a way for those people to recover, or even prepare.
> 
> My initial fix was to remove the dconf storage. But that file actually
> contained a lot of configuration, and I was unwilling to lose it.
> 
> I came up with the following solution, that allows to keep most of the old
> configuration, and will simply reset the list of enabled cinnamon applets.
> 
> The following commands can be executed from within a console window, even if
> the user is unable to start a graphical environment. The user should log in
> to the console using the affected user account, and execute the following
> commands:
> 
> $ export `dbus-launch`
>   # comment: above command will run dbus and make environment variables
>   #          available, that will allow the following commands to work.
> $ dconf reset /org/cinnamon/enabled-applets
> $ dconf reset /org/cinnamon/next-applet-id
> 
> The above commands should succeed without errors.
> Afterwards, it should be possible to login with cinnamon.

does this scratch build fix your brightness applet? https://koji.fedoraproject.org/koji/taskinfo?taskID=5443512
Comment 8 Kai Engert (:kaie) 2013-05-30 20:16:27 EDT
(In reply to leigh scott from comment #7)
> 
> does this scratch build fix your brightness applet?
> https://koji.fedoraproject.org/koji/taskinfo?taskID=5443512

Yes, it does, great work!
I could add the applet, and it correctly adjusts brightness.
Comment 9 Fedora Update System 2013-05-30 20:49:11 EDT
cinnamon-1.8.6-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/cinnamon-1.8.6-1.fc19
Comment 10 Fedora Update System 2013-05-31 14:09:50 EDT
Package cinnamon-1.8.6-2.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing cinnamon-1.8.6-2.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-9735/cinnamon-1.8.6-2.fc19
then log in and leave karma (feedback).
Comment 11 Fedora Update System 2013-06-02 13:59:53 EDT
cinnamon-1.9.1-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/cinnamon-1.9.1-1.fc19
Comment 12 Fedora Update System 2013-06-02 23:41:17 EDT
cinnamon-1.9.1-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 13 Adam Williamson 2013-07-01 02:05:03 EDT
Sounds like this doesn't need commonbugs any more.

Note You need to log in before you can comment on or make changes to this bug.