Bug 968063 - smalltalk-mode-init.el[c]: inhibit-first-line-modes-regexps not defined
smalltalk-mode-init.el[c]: inhibit-first-line-modes-regexps not defined
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gnu-smalltalk (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jochen Schmitt
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-28 19:02 EDT by Edgar Hoch
Modified: 2013-06-07 00:35 EDT (History)
2 users (show)

See Also:
Fixed In Version: gnu-smalltalk-3.2.5-2.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-06 23:00:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Edgar Hoch 2013-05-28 19:02:01 EDT
Description of problem:
After starting emacs I get the following error:

load: Symbol's value as variable is void: inhibit-first-line-modes-regexps

This error is caused by the command

(push "\\.star\\'" inhibit-first-line-modes-regexps)

in the file(s)
/usr/share/emacs/site-lisp/site-start.d/smalltalk-mode-init.el
/usr/share/emacs/site-lisp/site-start.d/smalltalk-mode-init.elc


See file /usr/share/emacs/24.2/etc/NEWS for a solution:

*** The variable `inhibit-first-line-modes-regexps' has been renamed
to `inhibit-local-variables-regexps'.  As the name suggests, it now
applies to ALL file local variables, not just -*- lines.  The
associated `inhibit-first-line-modes-suffixes' has been renamed in the
corresponding way.


Could you please provide fixed packages?


Version-Release number of selected component (if applicable):
emacs-gnu-smalltalk-el-3.2.4-3.fc18.2.noarch
emacs-gnu-smalltalk-3.2.4-3.fc18.2.noarch
emacs-24.2-18.fc18.x86_64


How reproducible:
Always.

Steps to Reproduce:
1. Install the packages listed above.
2. Start emacs and listen the message line.

Actual results:
load: Symbol's value as variable is void: inhibit-first-line-modes-regexps

Expected results:
No error.
Comment 1 Fedora Update System 2013-05-29 12:58:12 EDT
gnu-smalltalk-3.2.5-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/gnu-smalltalk-3.2.5-2.fc19
Comment 2 Fedora Update System 2013-05-29 13:06:49 EDT
gnu-smalltalk-3.2.5-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/gnu-smalltalk-3.2.5-2.fc18
Comment 3 Fedora Update System 2013-05-29 22:55:36 EDT
Package gnu-smalltalk-3.2.5-2.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gnu-smalltalk-3.2.5-2.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-9600/gnu-smalltalk-3.2.5-2.fc18
then log in and leave karma (feedback).
Comment 4 Edgar Hoch 2013-05-30 15:37:37 EDT
Many thanks, the new version works for me.
Comment 5 Fedora Update System 2013-06-06 23:00:34 EDT
gnu-smalltalk-3.2.5-2.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Fedora Update System 2013-06-07 00:35:43 EDT
gnu-smalltalk-3.2.5-2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.