Bug 968090 - ContentSearch is not showing all of my products
ContentSearch is not showing all of my products
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI (Show other bugs)
6.0.1
Unspecified Unspecified
unspecified Severity medium (vote)
: Unspecified
: --
Assigned To: David Davis
Hayk Hovsepyan
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-28 22:07 EDT by Og Maciel
Modified: 2013-07-18 17:19 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-18 17:19:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot (45.03 KB, image/png)
2013-05-28 22:07 EDT, Og Maciel
no flags Details

  None (edit)
Description Og Maciel 2013-05-28 22:07:54 EDT
Created attachment 754115 [details]
screenshot

Description of problem:

The attached screenshot (Firefox 21.0 on Fedora 18) shows that when searching for Packages in the Content Search page, only one of my two products are being listed for the PublishedCCVD1 composite content view. There should be two products listed.

Version-Release number of selected component (if applicable):

* apr-util-ldap-1.3.9-3.el6_0.1.x86_64
* candlepin-0.8.9-1.el6_4.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.8.9-1.el6_4.noarch
* candlepin-tomcat6-0.8.9-1.el6_4.noarch
* elasticsearch-0.19.9-8.el6sat.noarch
* foreman-1.1.10002-40.noarch
* foreman-installer-puppet-concat-0-2.d776701.el6sat.noarch
* foreman-installer-puppet-dhcp-0-5.3a4a13c.el6sat.noarch
* foreman-installer-puppet-dns-0-7.fcae203.el6sat.noarch
* foreman-installer-puppet-foreman-0-6.568c5c4.el6sat.noarch
* foreman-installer-puppet-foreman_proxy-0-8.bd1e35d.el6sat.noarch
* foreman-installer-puppet-puppet-0-3.ab46748.el6sat.noarch
* foreman-installer-puppet-tftp-0-5.ea6c5e5.el6sat.noarch
* foreman-installer-puppet-xinetd-0-50a267b8.git.0.44aca6a.el6sat.noarch
* foreman-postgresql-1.1.10002-40.noarch
* foreman-proxy-1.1.10001-1.el6sat.noarch
* foreman-proxy-installer-1.0.1-7.f5ae2cd.el6sat.noarch
* katello-1.4.2-7.el6sat.noarch
* katello-all-1.4.2-7.el6sat.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.4.2-2.el6sat.noarch
* katello-cli-1.4.2-6.el6sat.noarch
* katello-cli-common-1.4.2-6.el6sat.noarch
* katello-common-1.4.2-7.el6sat.noarch
* katello-configure-1.4.3-10.el6sat.noarch
* katello-configure-foreman-1.4.3-10.el6sat.noarch
* katello-foreman-all-1.4.2-7.el6sat.noarch
* katello-glue-candlepin-1.4.2-7.el6sat.noarch
* katello-glue-elasticsearch-1.4.2-7.el6sat.noarch
* katello-glue-pulp-1.4.2-7.el6sat.noarch
* katello-qpid-broker-key-pair-1.0-1.noarch
* katello-qpid-client-key-pair-1.0-1.noarch
* katello-selinux-1.4.3-3.el6sat.noarch
* openldap-2.4.23-31.el6.x86_64
* pulp-rpm-plugins-2.1.1-1.el6sat.noarch
* pulp-selinux-2.1.1-1.el6sat.noarch
* pulp-server-2.1.1-1.el6sat.noarch
* python-ldap-2.3.10-1.el6.x86_64
* ruby193-rubygem-ldap_fluff-0.1.7-3.el6sat.noarch
* ruby193-rubygem-net-ldap-0.2.2-7.el6_4.noarch
* signo-0.0.12-1.el6sat.noarch
* signo-katello-0.0.12-1.el6sat.noarch

How reproducible:


Steps to Reproduce:
* Created Provider1, Product1 and Repo1
* Created Provider2, Product2 and Repo2
* Synced both products
* Created ContentView1, added Product1 and published
* Created ContentView2, added Product2 and published
* Created CompositeContentView1, added both published content views and published
* Promoted published CompositeContentView1
* Browse the Content Search page and search for all packages

Actual results:

CompositeContentView1 only shows Product1

Expected results:

CompositeContentView1 should show Product1 and Product2

Additional info:
# ls -l /var/lib/pulp/published/http/repos/Org1/DEV/PublishedCCVD1/custom/
total 8
drwxr-xr-x. 2 apache apache 4096 May 28 17:47 Product1
drwxr-xr-x. 2 apache apache 4096 May 28 17:47 Product2
Comment 1 David Davis 2013-06-06 16:45:32 EDT
https://github.com/Katello/katello/pull/2442
Comment 2 Brad Buckingham 2013-06-11 05:58:55 EDT
Moving to POST, since PR was merged.
Comment 4 Brad Buckingham 2013-06-11 15:46:07 EDT
Mass move to ON_QA
Comment 5 Hayk Hovsepyan 2013-06-12 04:09:10 EDT
Verified on revision:
Katello-Katello-Installation-RegisterRHNClassic-1.1-3.noarch
foreman-installer-puppet-tftp-0-5.ea6c5e5.el6sat.noarch
foreman-1.1.10009-1.noarch
katello-certs-tools-1.4.2-2.el6sat.noarch
pulp-server-2.1.1-1.el6sat.noarch
katello-configure-1.4.3-15.el6sat.noarch
openldap-2.4.23-31.el6.x86_64
candlepin-scl-quartz-2.1.5-5.el6_4.noarch
katello-glue-elasticsearch-1.4.2-12.el6sat.noarch
katello-1.4.2-12.el6sat.noarch
candlepin-tomcat6-0.8.9-1.el6_4.noarch
katello-qpid-broker-key-pair-1.0-1.noarch
candlepin-cert-consumer-cfseserver5.usersys.redhat.com-1.0-1.noarch
signo-0.0.16-1.el6sat.noarch
apr-util-ldap-1.3.9-3.el6_0.1.x86_64
Katello-Katello-Installation-Satellite6Latest-1.0-8.noarch
foreman-installer-puppet-concat-0-2.d776701.git.0.21ef926.el6sat.noarch
candlepin-scl-runtime-1-5.el6_4.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-qpid-client-key-pair-1.0-1.noarch
pulp-rpm-handlers-2.1.1-1.el6sat.noarch
foreman-installer-puppet-puppet-0-3.ab46748.el6sat.noarch
katello-cli-1.4.2-7.el6sat.noarch
foreman-postgresql-1.1.10009-1.noarch
pulp-rpm-plugins-2.1.1-1.el6sat.noarch
pulp-selinux-2.1.1-1.el6sat.noarch
foreman-proxy-installer-1.0.1-8.f5ae2cd.el6sat.noarch
ruby193-rubygem-ldap_fluff-0.2.2-1.el6sat.noarch
foreman-proxy-1.1.10003-1.el6sat.noarch
candlepin-scl-1-5.el6_4.noarch
elasticsearch-0.19.9-8.el6sat.noarch
katello-common-1.4.2-12.el6sat.noarch
katello-selinux-1.4.3-3.el6sat.noarch
katello-glue-candlepin-1.4.2-12.el6sat.noarch
candlepin-selinux-0.8.9-1.el6_4.noarch
katello-all-1.4.2-12.el6sat.noarch
katello-agent-1.4.2-4.el6sat.noarch
foreman-installer-puppet-xinetd-0-50a267b8.git.0.44aca6a.el6sat.noarch
foreman-installer-puppet-dhcp-0-5.3a4a13c.el6sat.noarch
katello-cli-common-1.4.2-7.el6sat.noarch
candlepin-scl-rhino-1.7R3-1.el6_4.noarch
python-ldap-2.3.10-1.el6.x86_64
ruby193-rubygem-net-ldap-0.3.1-2.el6sat.noarch
foreman-installer-puppet-foreman-0-6.568c5c4.el6sat.noarch
signo-katello-0.0.16-1.el6sat.noarch
katello-glue-pulp-1.4.2-12.el6sat.noarch
katello-configure-foreman-1.4.3-15.el6sat.noarch
candlepin-0.8.9-1.el6_4.noarch
katello-foreman-all-1.4.2-12.el6sat.noarch
Katello-Katello-Configuration-KatelloClient-1.1-47.noarch
foreman-installer-puppet-foreman_proxy-0-8.bd1e35d.el6sat.noarch
foreman-installer-puppet-dns-0-7.fcae203.el6sat.noarch
Katello-Katello-Sanity-ImportKeys-1.2-1.noarch


Now it shows packages from all repos.
Comment 6 Mike McCune 2013-07-18 17:19:22 EDT
mass move to CLOSED:CURRENTRELEASE since MDP1 has been released.

Note You need to log in before you can comment on or make changes to this bug.