Bug 968098 - few issues around Host::Base#merge_facts and fact names
few issues around Host::Base#merge_facts and fact names
Status: CLOSED NOTABUG
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Provisioning (Show other bugs)
6.0.1
Unspecified Unspecified
unspecified Severity unspecified (vote)
: Unspecified
: --
Assigned To: Katello Bug Bin
Corey Welton
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-28 22:26 EDT by Sam Kottler
Modified: 2014-06-18 04:14 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-05 15:26:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sam Kottler 2013-05-28 22:26:15 EDT
Description of problem:
1) it seems that fact names are duplicated in the db, not sure how this happens but I'm guessing this is not happening in v1.1

regardless, we should fix that + have a migration to fix that in the db.

2) since 991cd8ae19 i see the following in the logs:

FactName(#69884217724060) expected, got Fixnum(#69884320844400)

further inspect of the code reveals this method is full with logic that do not make sense, I think its best to look at it before the 1.2 release.

Additional info:
Fixed upstream in b365f0a9cdb1839e07517a572b753f67ea1442e5.
Comment 1 Og Maciel 2013-05-28 22:27:36 EDT
How do you verify this?
Comment 2 Mike McCune 2013-05-29 18:36:52 EDT
mass-triage since these are all POST/MODIFIED
Comment 3 Corey Welton 2013-06-05 15:26:27 EDT
Devtask, QE Closing.

Note You need to log in before you can comment on or make changes to this bug.