This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 968109 - No A record created in domain when provisioning image based vm
No A record created in domain when provisioning image based vm
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Provisioning (Show other bugs)
6.0.2
Unspecified Unspecified
unspecified Severity unspecified (vote)
: Unspecified
: --
Assigned To: Katello Bug Bin
Katello QA List
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-28 22:46 EDT by Sam Kottler
Modified: 2014-06-18 04:14 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-18 14:36:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sam Kottler 2013-05-28 22:46:58 EDT
Description of problem:
When I provision a new vm in ec2 and I choose a domain on my Foreman server no CNAME or A record is created. I see the following output, which doesn't indicate anything is happening with DNS locally. It would be great to get a CNAME pointing at the EC2 server name. Not sure why I need (or would be able) to select a domain if it's not going to set up a record.

If this ends up not being a bug I'd like to request as a feature that a CNAME be created.

new In Progress
completed - Settings up compute instance test2.ec2.devlab.redhat.com
completed - Acquiring IP address for test2.ec2.devlab.redhat.com
completed - Querying instance details for test2.ec2.devlab.redhat.com
completed - Preparing Post installation script for test2.ec2.devlab.redhat.com
running - Waiting for test2.ec2.devlab.redhat.com to come online
pending - Enable Certificate generation for test2.ec2.devlab.redhat.com
pending - Configuring instance test2.ec2.devlab.redhat.com via SSH

Additional info:
Fixed upstream in 022c4060d3e7a06519fcfe76f09d255877c15d85.
Comment 1 Mike McCune 2013-05-29 18:36:46 EDT
mass-triage since these are all POST/MODIFIED
Comment 2 Dominic Cleal 2013-09-18 14:36:49 EDT
Shipped in MDP1.

Note You need to log in before you can comment on or make changes to this bug.