Bug 968112 - Handle backtraces correctly in compute orchestration errors
Handle backtraces correctly in compute orchestration errors
Status: CLOSED NOTABUG
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Provisioning (Show other bugs)
6.0.1
Unspecified Unspecified
unspecified Severity unspecified (vote)
: Unspecified
: --
Assigned To: Katello Bug Bin
Corey Welton
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-28 22:52 EDT by Sam Kottler
Modified: 2014-06-18 04:14 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-05 15:24:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sam Kottler 2013-05-28 22:52:47 EDT
Description of problem:
In 1.2-RC1, when I try to provision a new ovirt VM I get the error message in the logs: 
Failed to save: Settings up compute instance s05.montleon.priv task failed with the following error: undefined method `join' for #<String:0x00000007bc11f8>

All I get in the UI is: 
Settings up compute instance s05.montleon.priv task failed with the following error: undefined method `join' for #

I guess this is something to do with provisioning on compute resources or ovirt specifically, as I was able to create a 'bare metal' host entry no problem.

Additional info:
Fixed upstream in 46d8e3429f75692f5b009c3b53d0705ae169445d.
Comment 1 Sam Kottler 2013-05-29 17:22:25 EDT
MDP1 is only for libvirt, so Og and I agreed to not require QE ack for this fix.
Comment 2 Mike McCune 2013-05-29 18:36:43 EDT
mass-triage since these are all POST/MODIFIED
Comment 3 Corey Welton 2013-06-05 15:24:45 EDT
Devtask, QE closing.

Note You need to log in before you can comment on or make changes to this bug.