Bug 968142 - [abrt] system-config-printer-1.4.1-3.fc19: PhysicalDevice.py:181:get_info:UnicodeDecodeError: 'ascii' codec can't decode byte 0xe2 in position 34: ordinal not in range(128)
[abrt] system-config-printer-1.4.1-3.fc19: PhysicalDevice.py:181:get_info:Uni...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: system-config-printer (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
abrt_hash:431cfe630e140325c602228eb66...
: Reopened
: 1108903 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-29 01:05 EDT by Michael Chapman
Modified: 2014-07-09 20:23 EDT (History)
4 users (show)

See Also:
Fixed In Version: system-config-printer-1.4.5-1.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-07-09 20:23:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (1.24 KB, text/plain)
2013-05-29 01:06 EDT, Michael Chapman
no flags Details
File: core_backtrace (767 bytes, text/plain)
2013-05-29 01:06 EDT, Michael Chapman
no flags Details
File: dso_list (78 bytes, text/plain)
2013-05-29 01:06 EDT, Michael Chapman
no flags Details
File: environ (1.95 KB, text/plain)
2013-05-29 01:06 EDT, Michael Chapman
no flags Details

  None (edit)
Description Michael Chapman 2013-05-29 01:05:57 EDT
Version-Release number of selected component:
system-config-printer-1.4.1-3.fc19

Additional info:
reporter:       libreport-2.1.4
cmdline:        /usr/bin/python /usr/share/system-config-printer/system-config-printer.py
executable:     /usr/share/system-config-printer/system-config-printer.py
kernel:         3.9.4-300.fc19.x86_64
runlevel:       N 5
uid:            1000

Truncated backtrace:
PhysicalDevice.py:181:get_info:UnicodeDecodeError: 'ascii' codec can't decode byte 0xe2 in position 34: ordinal not in range(128)

Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/dbus/connection.py", line 604, in msg_reply_handler
    reply_handler(*message.get_args_list(**get_args_opts))
  File "/usr/share/system-config-printer/dnssdresolve.py", line 107, in _reply
    self._resolved ()
  File "/usr/share/system-config-printer/dnssdresolve.py", line 93, in _resolved
    self._reply_handler (self._devices)
  File "/usr/share/system-config-printer/newprinter.py", line 1715, in <lambda>
    devices))
  File "/usr/share/system-config-printer/newprinter.py", line 1718, in dnssd_resolve_reply
    self.add_devices (devices, current_uri, no_more=True)
  File "/usr/share/system-config-printer/newprinter.py", line 2070, in add_devices
    info = device.get_info ()
  File "/usr/share/system-config-printer/PhysicalDevice.py", line 181, in get_info
    info.find(self._network_host) == -1) and \
UnicodeDecodeError: 'ascii' codec can't decode byte 0xe2 in position 34: ordinal not in range(128)

Local variables in innermost frame:
info: 'HP LaserJet 3390 (D22C8F) @ Lauren\xe2\x80\x99s Mac mini'
self: <PhysicalDevice.PhysicalDevice (,,)>
Comment 1 Michael Chapman 2013-05-29 01:06:02 EDT
Created attachment 754154 [details]
File: backtrace
Comment 2 Michael Chapman 2013-05-29 01:06:06 EDT
Created attachment 754155 [details]
File: core_backtrace
Comment 3 Michael Chapman 2013-05-29 01:06:10 EDT
Created attachment 754156 [details]
File: dso_list
Comment 4 Michael Chapman 2013-05-29 01:06:13 EDT
Created attachment 754157 [details]
File: environ
Comment 5 Tim Waugh 2013-05-30 07:12:33 EDT
What does this command say?: su -c 'lpinfo -v'
Comment 6 Michael Chapman 2013-05-30 20:55:51 EDT
network smb
network http
network socket
network ipps
direct hp
network https
network beh
serial serial:/dev/ttyS0?baud=115200
network lpd
network ipp
direct hpfax
network dnssd://HP%20LaserJet%203390%20(D22C8F)._pdl-datastream._tcp.local/
network dnssd://HP%20LaserJet%203390%20(D22C8F)%20%40%20Lauren%E2%80%99s%20Mac%20mini._ipp._tcp.local/cups
network dnssd://HP%20LaserJet%20M1536dnf%20MFP%20%40%20Chiaki._ipp._tcp.local/cups
network dnssd://Sales%20Colour%20Printer._pdl-datastream._tcp.local/
network dnssd://Sales%20Colour%20Printer%20%40%20Lauren%E2%80%99s%20Mac%20mini._ipp._tcp.local/cups

system-config-printer appears to have tripped up on the %E2%80%99 sequence -- UTF-8 for a Unicode right single quotation mark.

The crash occurred while I was in the "New Printer" dialog, browsing the available network printers. It's a bit odd, though... no matter what I do, I can't seem to crash it at all now.
Comment 7 Tim Waugh 2013-05-31 12:35:52 EDT
Thanks.  I couldn't reproduce it either. :-(

I think it should be fixed upstream in commit c3f0f01.
Comment 8 Fedora Update System 2013-06-07 12:29:20 EDT
system-config-printer-1.4.1-6.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/system-config-printer-1.4.1-6.fc19
Comment 9 Fedora Update System 2013-06-07 22:57:05 EDT
Package system-config-printer-1.4.1-6.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing system-config-printer-1.4.1-6.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-10351/system-config-printer-1.4.1-6.fc19
then log in and leave karma (feedback).
Comment 10 Fedora Update System 2013-06-13 02:36:36 EDT
system-config-printer-1.4.1-6.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Jiri Popelka 2014-06-13 06:07:43 EDT
*** Bug 1108903 has been marked as a duplicate of this bug. ***
Comment 13 Peter H. Jones 2014-06-19 18:02:28 EDT
Another user experienced a similar problem:

Installing/using a Brother HL2270DW printer. I have installed the drivers from Brother.

reporter:       libreport-2.2.2
cmdline:        /usr/bin/python /usr/share/system-config-printer/system-config-printer.py
executable:     /usr/share/system-config-printer/system-config-printer.py
kernel:         3.14.8-200.fc20.x86_64
package:        system-config-printer-1.4.4-1.fc20
reason:         PhysicalDevice.py:199:get_info:UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 55: ordinal not in range(128)
runlevel:       N 5
type:           Python
uid:            3000
Comment 14 Tim Waugh 2014-06-23 11:45:45 EDT
_network_host is only ever assigned a value in two places, and one of them is always UTF-8.

I've pushed a change to make sure the other one is UTF-8 as well:

https://git.fedorahosted.org/cgit/system-config-printer.git/commit/?h=1.4.x&id=022308bc6f331ae6ca527a61804599ab26cc4d7c
Comment 15 Fedora Update System 2014-07-04 12:31:40 EDT
system-config-printer-1.4.5-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/system-config-printer-1.4.5-1.fc20
Comment 16 Fedora Update System 2014-07-05 10:55:33 EDT
Package system-config-printer-1.4.5-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing system-config-printer-1.4.5-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-8100/system-config-printer-1.4.5-1.fc20
then log in and leave karma (feedback).
Comment 17 Fedora Update System 2014-07-09 20:23:56 EDT
system-config-printer-1.4.5-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.