Bug 968155 - [rhevm] Option get host name instead host ID in RHEVM logs - Exception message is VdcBLLException: Vds with id: vdsid=e078d7ac-279d-49b3-898b-48df88d4a923 was not found
[rhevm] Option get host name instead host ID in RHEVM logs - Exception messag...
Status: CLOSED CANTFIX
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.2.0
x86_64 Linux
unspecified Severity low
: ---
: 3.2.0
Assigned To: Nobody's working on this, feel free to take it
vvyazmin@redhat.com
storage
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-29 02:35 EDT by vvyazmin@redhat.com
Modified: 2016-02-10 14:10 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-29 02:40:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
## Logs rhevm, vdsm, libvirt, thread dump, vds_table (1.72 MB, application/x-gzip)
2013-05-29 02:35 EDT, vvyazmin@redhat.com
no flags Details

  None (edit)
Description vvyazmin@redhat.com 2013-05-29 02:35:20 EDT
Created attachment 754197 [details]
## Logs rhevm, vdsm, libvirt, thread dump, vds_table

Description of problem: 
Option get host name instead host ID in RHEVM logs - Exception message is VdcBLLException: Vds with id: vdsid=e078d7ac-279d-49b3-898b-48df88d4a923
 was not found

Version-Release number of selected component (if applicable):
RHEVM 3.2 - SF17.1 environment: 

RHEVM: rhevm-3.2.0-11.28.el6ev.noarch 
VDSM: vdsm-4.10.2-21.0.el6ev.x86_64 
LIBVIRT: libvirt-0.10.2-18.el6_4.5.x86_64 
QEMU & KVM: qemu-kvm-rhev-0.12.1.2-2.355.el6_4.3.x86_64 
SANLOCK: sanlock-2.6-2.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Create iSCSI DC with 50 hosts (in my case 50 fake hosts)
2. Try to add first Storage Domain
  
Actual results:
In RHEVM log I host ID instead host name

Expected results:
Option get host name instead host ID in RHEVM logs

Impact on user:
User can get host name only via query in DB or API – see workaround

Workaround:
1. psql -U postgres engine -c 'select * from vds;' | grep e078d7ac-279d-49b3-898b-48df88d4a923 | less -S
2. https://green-vdsc.qa.lab.tlv.redhat.com/api/hosts/e078d7ac-279d-49b3-898b-48df88d4a923

Additional info:

/var/log/ovirt-engine/engine.log

2013-05-28 18:11:33,583 ERROR [org.ovirt.engine.core.vdsbroker.ResourceManager] (ajp-/127.0.0.1:8702-7) Cannot get vdsManager for vdsid=e078d7ac-279d-49b3-898b-48df88d4a923
2013-05-28 18:11:33,583 ERROR [org.ovirt.engine.core.vdsbroker.ResourceManager] (ajp-/127.0.0.1:8702-7) CreateCommand failed: org.ovirt.engine.core.common.errors.VdcBLLException: VdcBLLException: V
ds with id: e078d7ac-279d-49b3-898b-48df88d4a923 was not found
        at org.ovirt.engine.core.vdsbroker.vdsbroker.VdsBrokerCommand.initializeVdsBroker(VdsBrokerCommand.java:50) [engine-vdsbroker.jar:]
        at org.ovirt.engine.core.vdsbroker.vdsbroker.VdsBrokerCommand.<init>(VdsBrokerCommand.java:29) 

.
.
.


2013-05-28 18:11:33,590 ERROR [org.ovirt.engine.core.bll.storage.GetDeviceListQuery] (ajp-/127.0.0.1:8702-7) Query GetDeviceListQuery failed. Exception message is VdcBLLException: Vds with id: e078d7ac-279d-49b3-898b-48df88d4a923 was not found

/var/log/vdsm/vdsm.log
Comment 1 Itamar Heim 2013-05-29 02:40:44 EDT
while we need to solve the bug 968150, if the code did not locate the host uuid, obviously, the exception can't get the name of a host not found (i understand it is actually in the db and this looks like a bug, but the error path in this case is for an invalid uuid most likely...)

Note You need to log in before you can comment on or make changes to this bug.