Bug 968162 - [RHEVM-RHS] Volume set help option for "nfs.disable" is not available with "gluster volume set help" output and that affects setting/editing that option through RHEVM UI
[RHEVM-RHS] Volume set help option for "nfs.disable" is not available with "g...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterfs (Show other bugs)
2.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: rjoseph
Rejy M Cyriac
Affects RHEVM-RHS Integration Testing
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-29 03:03 EDT by SATHEESARAN
Modified: 2013-09-23 18:29 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
virt rhev integration
Last Closed: 2013-09-23 18:29:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
contains the output of "gluster volume set help" (10.58 KB, text/plain)
2013-05-29 03:03 EDT, SATHEESARAN
no flags Details

  None (edit)
Description SATHEESARAN 2013-05-29 03:03:29 EDT
Created attachment 754201 [details]
contains the output of "gluster volume set help"

Description of problem:
volume set help option for "nfs.disable" is not available under "gluster volume set help", thereby setting/editing the same option (nfs.disable) through RHEVM UI, also becomes erroneous

Version-Release number of selected component (if applicable):
RHEVM : 3.1.4.1
RHS   : RHS 2.0 U5 [ glusterfs 3.3.0.9rhs-1.el6rhs.x86_64 ]

How reproducible:
Always

Steps to Reproduce:
1. grep for nfs.disable option in the help displayed with "gluster volume set help"

Actual results:
nfs.disable option is not available

Expected results:
nfs.disable option should be available and explained briefly

Additional info:
Attached the output of "gluster volume set help" in one of RHS Nodes
Comment 1 rjoseph 2013-06-28 01:35:17 EDT
Option available in latest build (RHS-2.1 *) .
Comment 2 Gowrishankar Rajaiyan 2013-07-23 07:35:12 EDT
rjoseph,

Could you please let us know on why is the resolution of this bug WONTFIX if the options are made available ? 

I do not have a "needinfo" option on a closed bug, hence moving it to ASSIGNED to have this answered.

thank you,
Shanks
Comment 3 Vivek Agarwal 2013-07-23 07:43:53 EDT
This has been fixed for 2.1, do not plan to backport it to 2.0.
Comment 4 Scott Haines 2013-07-24 03:19:36 EDT
Per discussion w/ Shanks, and Vivek, targeting for 2.1.0.
Comment 5 Rejy M Cyriac 2013-08-03 12:04:37 EDT
Verified on glusterfs*-3.4.0.14rhs-1.el6rhs.x86_64

'gluster volume set help' now has the entry given below

------------------------------------------------------

Option: nfs.disable
Default Value: false
Description: This option is used to start or stop NFS serverfor individual volume.

------------------------------------------------------

Setting/editing the option through RHEVM UI is possible
Comment 6 Scott Haines 2013-09-23 18:29:52 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.