Bug 968207 - CLI - cannot list system packages
CLI - cannot list system packages
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Hammer (Show other bugs)
Nightly
Unspecified Unspecified
unspecified Severity low (vote)
: Unspecified
: --
Assigned To: Justin Sherrill
Garik Khachikyan
Justin Sherrill
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-29 04:32 EDT by Ales Dujicek
Modified: 2015-01-04 16:59 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-18 17:18:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ales Dujicek 2013-05-29 04:32:24 EDT
Description of problem:

When you register system and then try to list its packages, you get exception

system packages --name system  --org org
undefined method `[]' for #<Glue::Pulp::SimplePackage:0x00000008193bd0>


Version-Release number of selected component (if applicable):
katello-glue-candlepin-1.4.2-1.git.469.ba512a5.el6.noarch
katello-glue-pulp-1.4.2-1.git.469.ba512a5.el6.noarch
signo-katello-0.0.9-1.el6.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-cli-1.4.2-1.git.71.2a2d883.el6.noarch
katello-qpid-broker-key-pair-1.0-1.noarch
katello-repos-1.4.2-1.el6.noarch
katello-cli-common-1.4.2-1.git.71.2a2d883.el6.noarch
katello-certs-tools-1.4.2-1.el6.noarch
katello-configure-1.4.3-1.git.41.e1043b5.el6.noarch
katello-common-1.4.2-1.git.469.ba512a5.el6.noarch
katello-all-1.4.2-1.git.469.ba512a5.el6.noarch
katello-qpid-client-key-pair-1.0-1.noarch
katello-selinux-1.4.3-1.git.3.ce8227b.el6.noarch
katello-glue-elasticsearch-1.4.2-1.git.469.ba512a5.el6.noarch
katello-1.4.2-1.git.469.ba512a5.el6.noarch

How reproducible:
always

Steps to Reproduce:
1. org create --name org
2. subscription-manager register --name system --org org --force
3. system packages --name system  --org org

Actual results:
undefined method `[]' for #<Glue::Pulp::SimplePackage:0x00000008193bd0>
Comment 1 Justin Sherrill 2013-06-04 16:24:04 EDT
https://github.com/Katello/katello/pull/2423
Comment 3 Brad Buckingham 2013-06-06 17:58:51 EDT
Mass move to ON_QA
Comment 5 Garik Khachikyan 2013-06-07 09:01:54 EDT
QA whiteboard contains: https://github.com/gkhachik/katello-api/issues/428
Comment 6 Garik Khachikyan 2013-06-07 09:04:01 EDT
# VERIFIED

It works now for recent drop provided Fri, 06.Jun:

katello -uadmin -pPASS system packages --uuid 196043f3-7f3d-4584-bb44-0598706ad571 --org BUG-968207 | wc -l
> 1009

---
candlepin-0.8.9-1.el6_4.noarch
candlepin-cert-consumer-hp-ml370g6-01.rhts.eng.bos.redhat.com-1.0-1.noarch
candlepin-scl-1-5.el6_4.noarch
candlepin-scl-quartz-2.1.5-5.el6_4.noarch
candlepin-scl-rhino-1.7R3-1.el6_4.noarch
candlepin-scl-runtime-1-5.el6_4.noarch
candlepin-selinux-0.8.9-1.el6_4.noarch
candlepin-tomcat6-0.8.9-1.el6_4.noarch
elasticsearch-0.19.9-8.el6sat.noarch
katello-1.4.2-10.el6sat.noarch
katello-agent-1.4.3-1.git.1.24fe511.el6.noarch
katello-all-1.4.2-10.el6sat.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-certs-tools-1.4.2-2.el6sat.noarch
katello-cli-1.4.2-7.el6sat.noarch
katello-cli-common-1.4.2-7.el6sat.noarch
katello-common-1.4.2-10.el6sat.noarch
katello-configure-1.4.3-14.el6sat.noarch
katello-configure-foreman-1.4.3-14.el6sat.noarch
katello-foreman-all-1.4.2-10.el6sat.noarch
katello-glue-candlepin-1.4.2-10.el6sat.noarch
katello-glue-elasticsearch-1.4.2-10.el6sat.noarch
katello-glue-pulp-1.4.2-10.el6sat.noarch
katello-qpid-broker-key-pair-1.0-1.noarch
katello-qpid-client-key-pair-1.0-1.noarch
katello-selinux-1.4.3-3.el6sat.noarch
m2crypto-0.21.1.pulp-8.el6sat.x86_64
mod_wsgi-3.4-1.pulp.el6sat.x86_64
pulp-rpm-handlers-2.1.1-1.el6sat.noarch
pulp-rpm-plugins-2.1.1-1.el6sat.noarch
pulp-selinux-2.1.1-1.el6sat.noarch
pulp-server-2.1.1-1.el6sat.noarch
python-isodate-0.5.0-1.pulp.el6sat.noarch
python-oauth2-1.5.170-3.pulp.el6sat.noarch
python-pulp-agent-lib-2.1.1-1.el6sat.noarch
python-pulp-bindings-2.1.1-1.el6.noarch
python-pulp-client-lib-2.1.1-1.el6.noarch
python-pulp-common-2.1.1-1.el6sat.noarch
python-pulp-rpm-common-2.1.1-1.el6sat.noarch
python-qpid-0.18-5.el6_4.noarch
python-rhsm-1.8.0-1.pulp.el6sat.x86_64
qpid-cpp-client-0.14-22.el6_3.x86_64
qpid-cpp-client-ssl-0.14-22.el6_3.x86_64
qpid-cpp-server-0.14-22.el6_3.x86_64
qpid-cpp-server-ssl-0.14-22.el6_3.x86_64
ruby193-rubygem-foreman-katello-engine-0.0.8-5.el6sat.noarch
ruby193-rubygem-katello-foreman-engine-0.0.3-4.el6sat.noarch
ruby193-rubygem-katello_api-0.0.3-2.el6_4.noarch
ruby193-rubygem-ldap_fluff-0.2.2-1.el6sat.noarch
signo-katello-0.0.16-1.el6sat.noarch
Comment 7 Mike McCune 2013-07-18 17:18:30 EDT
mass move to CLOSED:CURRENTRELEASE since MDP1 has been released.

Note You need to log in before you can comment on or make changes to this bug.