Bug 968210 - pmi interface silently discards data when over > 1024 metrics
pmi interface silently discards data when over > 1024 metrics
Status: CLOSED ERRATA
Product: Fedora EPEL
Classification: Fedora
Component: pcp (Show other bugs)
el6
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Nathan Scott
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-29 04:39 EDT by Marko Myllynen
Modified: 2014-02-16 17:19 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-16 17:19:24 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
test script (1.46 KB, application/x-perl)
2013-05-29 04:39 EDT, Marko Myllynen
no flags Details

  None (edit)
Description Marko Myllynen 2013-05-29 04:39:57 EDT
Created attachment 754261 [details]
test script

Description of problem:
When processing large metric sets it would seem that the pmi interface starts discarding data when going over 1024 metrics. The attached script runs fine but although there should be t_1020 ... t_1030 metrics in the created archive in reality there's only t_1020 ... t_1023 so the rest are being silently discarded.

Every call returns 0 when running the script so with real-life scripts/data it's hard to discover this kind of issue.

Version-Release number of selected component (if applicable):
pcp-3.8.0-1.el6.x86_64
Comment 1 Nathan Scott 2013-05-29 06:53:16 EDT
Thanks Marko - this is now fixed upstream via dev commit 90ae8bc and will appear in pcp-3.8.1 soon.
Comment 2 Fedora Update System 2013-06-19 03:40:10 EDT
pcp-3.8.1-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/pcp-3.8.1-1.el6
Comment 3 Fedora Update System 2013-07-04 16:01:50 EDT
pcp-3.8.1-1.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 4 Nathan Scott 2014-02-16 17:19:24 EST
EPEL packages continaining this fix long since released.  Manual bugzilla state maintenance needed, bodhi interaction botch on my part most likely meant this did not get closed automatically.

Note You need to log in before you can comment on or make changes to this bug.