Bug 968238 - [virtio-win][netkvm]Job of "NDISTest6.0-[2 Machine]- 2c_MiniRSSSendRecv" failed on HCK for win2k8-R2
[virtio-win][netkvm]Job of "NDISTest6.0-[2 Machine]- 2c_MiniRSSSendRecv" fail...
Status: CLOSED DUPLICATE of bug 977754
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virtio-win (Show other bugs)
6.5
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Yan Vugenfirer
Virtualization Bugs
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-29 05:36 EDT by guo jiang
Modified: 2013-10-13 20:56 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-26 09:22:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
HCK log (18.29 MB, application/x-zip-compressed)
2013-05-29 05:44 EDT, guo jiang
no flags Details
win2k8-R2-netkvm-build66.hckx (17.29 MB, application/zip)
2013-08-11 23:18 EDT, lijin
no flags Details

  None (edit)
Description guo jiang 2013-05-29 05:36:44 EDT
Description of problem:
Job of "NDISTest6.0-[2 Machine]- 2c_MiniRSSSendRecv" failed on HCK for win2k8-R2, no BSOD and error test log show "Miniport did not indicate all received net buffers on the expected processor"

Version-Release number of selected component (if applicable):
    * Red Hat Enterprise Linux Server release 6.4 (Santiago)
    * kernel-2.6.32-369.el6.x86_64    
    * qemu-img-rhev-0.12.1.2-2.359.el6.x86_64
    * virtio-win-prewhql-0.1-61
    * spice-server-0.12.0-12.el6.x86_64
    * seabios-0.6.1.2-27.el6.x86_64
    * vgabios-0.6b-3.7.el6.noarch

How reproducible:
5/5

Steps to Reproduce:
1.Boot guest with CLI:
 test guest:
/usr/libexec/qemu-kvm \
-m 6G \
-smp 8,cores=8 \
-cpu cpu64-rhel6,+x2apic \
-usb \
-device usb-tablet \
-drive file=win2k8-R2-nic1.raw,if=none,id=drive-ide0-0-0,werror=stop,rerror=stop,cache=none \
-device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0 \
-netdev tap,sndbuf=0,id=hostnet0,vhost=on,script=/etc/qemu-ifup-private,downscript=no \
-device virtio-net-pci,netdev=hostnet0,mac=00:34:23:14:32:42,bus=pci.0,addr=0x4,id=virtio-net-pci0 \
-netdev tap,sndbuf=0,id=hostnet2,script=/etc/qemu-ifup,downscript=no \
-device e1000,netdev=hostnet2,mac=00:23:54:14:22:20,bus=pci.0,addr=0x6 \
-uuid d7a5a5fe-2fb8-4525-b84c-3fb0e5b154a2 \
-no-kvm-pit-reinjection \
-chardev socket,id=111a,path=/tmp/monitor-win2k8-R2-61-nic1,server,nowait \
-mon chardev=111a,mode=readline \
-vnc :1 \
-vga cirrus \
-name win2k8-R2-nic1-61-HCK \
-rtc base=localtime,clock=host,driftfix=slew \
-global PIIX4_PM.disable_s3=0 \
-global PIIX4_PM.disable_s4=0 \
-monitor stdio

  support guest:
/usr/libexec/qemu-kvm \
-m 6G \
-smp 8,cores=8 \
-cpu cpu64-rhel6,+x2apic \
-usb \
-device usb-tablet \
-drive file=win2k8-R2-nic2.raw,if=none,id=drive-ide0-0-0,werror=stop,rerror=stop,cache=none \
-device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0 \
-netdev tap,sndbuf=0,id=hostnet0,vhost=on,script=/etc/qemu-ifup-private,downscript=no \
-device virtio-net-pci,netdev=hostnet0,mac=00:23:41:23:52:12,bus=pci.0,addr=0x4,id=virtio-net-pci0 \
-netdev tap,sndbuf=0,id=hostnet2,script=/etc/qemu-ifup,downscript=no \
-device e1000,netdev=hostnet2,mac=00:21:34:54:12:21,bus=pci.0,addr=0x6 \
-uuid bf9d1e01-5252-49c2-b6d6-972ea2b3d401 \
-no-kvm-pit-reinjection \
-chardev socket,id=111a,path=/tmp/monitor-win2k8-R2-61-nic2,server,nowait \
-mon chardev=111a,mode=readline \
-vnc :2 \
-vga cirrus \
-name win2k8-R2-nic2-61-HCK \
-rtc base=localtime,clock=host,driftfix=slew \
-global PIIX4_PM.disable_s3=0 \
-global PIIX4_PM.disable_s4=0 \
-monitor stdio


2.Run job "NDISTest6.0-[2 Machine]- 2c_MiniRSSSendRecv"

3.Run task "Run NDISTest Client"

Actual results:
Job fail

Expected results:
Job should pass without any error.

Additional info:
HCK task log show the following error:
"Miniport indicated packets with similar header fields on different processors"
Comment 1 guo jiang 2013-05-29 05:44:57 EDT
Created attachment 754276 [details]
HCK log
Comment 4 Min Deng 2013-07-09 02:31:39 EDT
The issue can reproduce on ovs config,so please double have a look,thanks.
Comment 6 lijin 2013-08-11 23:09:27 EDT
win2k8R2 guest hit the same issue with build66

package info:
qemu-kvm-rhev-0.12.1.2-2.377.el6.x86_64
kernel-2.6.32-393.el6.x86_64
seabios-0.6.1.2-27.el6.x86_64
virtio-win-preqwhql-66

the .hckx file will be upload later.
Comment 7 lijin 2013-08-11 23:18:54 EDT
Created attachment 785520 [details]
win2k8-R2-netkvm-build66.hckx
Comment 8 Yan Vugenfirer 2013-08-26 09:22:21 EDT

*** This bug has been marked as a duplicate of bug 977754 ***

Note You need to log in before you can comment on or make changes to this bug.