Bug 968252 - All web cartridges should have README file under .openshift/markers dir
All web cartridges should have README file under .openshift/markers dir
Status: CLOSED CURRENTRELEASE
Product: OpenShift Online
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Dan Mace
libra bugs
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-29 06:12 EDT by Meng Bo
Modified: 2015-05-14 19:20 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-07 18:54:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Meng Bo 2013-05-29 06:12:38 EDT
Description of problem:
.openshift/markers/README described which marker can be used for the cartridge. So it should be existed for all the web cartridges. 

Currently, only ruby1.8 ruby1.9 and Zend has such file.

Version-Release number of selected component (if applicable):
devenv_3282

How reproducible:
Always

Steps to Reproduce:
1.Create any type of app
2.Check if there is a README file under .openshift/markers dir from the git repo
3.

Actual results:
Only ruby1.8 ruy1.9 and Zend cartridge has such file for now.

[root@ip-10-154-145-32 v2]# find .|grep -i README|grep -i marker
./zend/versions/5.6/template/.openshift/markers/README
./ruby/versions/1.9/template/.openshift/markers/README
./ruby/versions/1.8/template/.openshift/markers/README


Expected results:
All the web cartridges should have the README for marker

Additional info:
Comment 1 Meng Bo 2013-07-07 22:23:44 EDT
Raise the severity since the bug will block us to test all the available markers.
Comment 2 Dan Mace 2013-07-10 11:38:50 EDT
https://github.com/openshift/origin-server/pull/3039

These marker README files should have been deleted with earlier documentation cleanups.

No cartridges should have such a README in the markers directory: any marker support for a cartridge is now documented in the top level cartridge README.md file.
Comment 3 openshift-github-bot 2013-07-10 14:35:38 EDT
Commit pushed to master at https://github.com/openshift/li

https://github.com/openshift/li/commit/a2460a86732b7880712ff075a95bf8d119446bfd
Bug 968252: Clean up old marker README files
Comment 4 openshift-github-bot 2013-07-10 14:35:39 EDT
Commit pushed to master at https://github.com/openshift/origin-server

https://github.com/openshift/origin-server/commit/04cfb3cb24d093695cb68cee94c317d299e4660c
Bug 968252: Clean up old marker README files
Comment 5 Meng Bo 2013-07-11 02:08:23 EDT
According to comment#2, all the marker README.md docs have been removed.

And can find them in the openshift-origin-cartridge-xxx/README.md


Move bug to verified.
Comment 8 openshift-github-bot 2013-07-26 12:49:53 EDT
Commit pushed to master at https://github.com/openshift/origin-server

https://github.com/openshift/origin-server/commit/f21d396565be9678f43dcb975360cae21e94f78d
Bug 968252: Add missing marker docs
Comment 9 Meng Bo 2013-07-29 02:00:28 EDT
Checked on devenv_3572, issue fixed.

Marker description for python and ruby exists.

Move to verified.

Note You need to log in before you can comment on or make changes to this bug.