Bug 968254 - Some of the accounts can not connect to INT via rhc or access app details page in web console
Some of the accounts can not connect to INT via rhc or access app details p...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Online
Classification: Red Hat
Component: Kubernetes (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Abhishek Gupta
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-29 06:15 EDT by Xiaoli Tian
Modified: 2015-05-14 20:17 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-11 00:12:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Xiaoli Tian 2013-05-29 06:15:54 EDT
Description of problem:
When trying to access app detail page from web console (https://int.openshift.redhat.com/app/console/applications/$appname) with account xtian+test1@redhat.com, it will always get "We appear to be having technical difficulties" page.

If trying to access INT with rhc,  it will get the following message
$ rhc domain show -l xtian+test1@redhat.com
The server did not respond correctly. This may be an issue with the server configuration or with your connection to the server (such as a Web proxy or firewall). Please verify that you can access the OpenShift server https://int.openshift.redhat.com/broker/rest/domains/domxint1/applications

$ rhc app show -a scaledown -l xtian+test1@redhat.com
The server did not respond correctly. This may be an issue with the server configuration or with your connection to the server (such as a Web proxy or firewall). Please verify that you can access the OpenShift server https://int.openshift.redhat.com/broker/rest/domains/domxint1/applications/scaledown

But could ssh to the app successfully:
[test@dhcp-9-116 0522]$ rhc ssh scaledown -l xtian+test1@redhat.com 
Connecting to 519c79306cec0e43f30000f4@scaledown-domxint1.int.rhcloud.com ...

    Note: Your application supports version 2 cartridges.

[scaledown-domxint1.int.rhcloud.com 519c79306cec0e43f30000f4]\> 


The app list for this accounts(which are all created after first INT deploy in this sprint and downloadable cartridge enabled ):
1)[mycartridges-domxint1.int.rhcloud.com 519c5eee03ef640738000077]\> ls
app-root  cdk  git
2)[selfperl1-domxint1.int.rhcloud.com 519c58576cec0e7ba8000001]\> ls
app-root  downloadable-mock-plugin  git  mysqltest  perlv2
3)[scaledown-domxint1.int.rhcloud.com 519c79306cec0e43f30000f4]\> ls
app-root  git  haproxy	perlv2


Other affected accounts: jinzhang+6@redhat.com , wjiang@redhat.com


Version-Release number of selected component (if applicable):
INT(devenv_3281)

How reproducible:
Always

Steps to Reproduce:
1.Login to INT with this account (xtian+test1@redhat.com), password is added in comment 1
2. or run rhc domain show -l xtian+test1@redhat.com --server int.openshift.redhat.com


Actual results:
Get "We appear to be having technical difficulties" page.
Can not connect to INT via rhc

Expected results:
It should work as normal

Additional info:

Other accounts could work well with the same browser , rhc, terminal:
[test@dhcp-9-116 0522]$ rhc domain show -l xtian+int1@redhat.com
Your authorization token has expired. Please sign in now to continue.
Password: ******

Applications in xtian domain
Comment 2 Abhishek Gupta 2013-05-29 18:38:45 EDT
The application was created in INT before a fix went in on friday. Please re-create the application and things should work just fine. The issue is with the component_name that is stored in mongo. In your application, it does not include the cartridge_vendor name.
Comment 3 Jianwei Hou 2013-05-30 01:19:07 EDT
The account is back to normal after having the problematic applications removed.
Moving to verified

Note You need to log in before you can comment on or make changes to this bug.