Bug 968264 - Changing the admin self password via Horizon, The user should be forced to re-login.
Changing the admin self password via Horizon, The user should be forced to re...
Status: CLOSED DUPLICATE of bug 967507
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-django-horizon (Show other bugs)
3.0
Unspecified Linux
medium Severity medium
: rc
: 4.0
Assigned To: Matthias Runge
Ami Jeain
: Regression, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-29 06:39 EDT by Nir Magnezi
Modified: 2015-06-04 17:51 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-19 03:43:55 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1226829 None None None Never

  None (edit)
Description Nir Magnezi 2013-05-29 06:39:26 EDT
Description of problem:
=======================
When the admin chooses to change it's own password via Horizon, The session becomes unusable and the user gets errors like:
Error: Unauthorized: Unable to retrieve user list.

In previous versions, The user was forced to re-login and had no errors following to the action I just mentioned

Changing the admin self password via Horizon, The user should be forced to re-login.

Version-Release number of selected component (if applicable):
=============================================================
python-django-horizon-2013.1.1-2.el6ost.noarch

How reproducible:
=================
2/2

Steps to Reproduce:
===================
1. Login to Horizon
2. Admin Tab --> Users
3. Click Edit User (admin)
4. Enter a new password and click update user

Actual results:
===============
Error: Unauthorized: Unable to retrieve user list.
Expected results:
=================
User should re-login and work with the UI without any errors.
Comment 4 Matthias Runge 2013-10-01 07:06:45 EDT
still valid in havana h3
Comment 5 Matthias Runge 2013-11-13 04:00:33 EST
There is a proposed fix: https://review.openstack.org/#/c/50408/
Comment 6 Matthias Runge 2013-11-19 03:43:55 EST

*** This bug has been marked as a duplicate of bug 967507 ***

Note You need to log in before you can comment on or make changes to this bug.