Bug 968284 - RFE: support for dnf
RFE: support for dnf
Status: CLOSED DEFERRED
Product: Fedora
Classification: Fedora
Component: fedora-upgrade (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Suchý
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-29 07:26 EDT by Karel Volný
Modified: 2013-05-29 07:50 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-29 07:50:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karel Volný 2013-05-29 07:26:00 EDT
Description of problem:
Since Fedora 19, the new package manager 'dnf' seems to be usable even for kernel upgrades, so I see no obstacle to using that instead of yum.
Please, add an optional support to do the upgrade using dnf instead of yum.

Version-Release number of selected component (if applicable):
fedora-upgrade-19.2-1.fc19.noarch

How reproducible:
always

Steps to Reproduce:
1. fedora-upgrade --help
2. fedora-upgrade --dnf

Actual results:
Going to upgrade your Fedora to rawhide.
Fedora 20 is currently under development.
Are you sure?
Hit Enter to continue or Ctrl + C to cancel.

Expected results:
1.
A tool to upgrade Fedora to next release using yum upgrade.

This is attempt to automatize steps as listed here:
https://fedoraproject.org/wiki/Upgrading_Fedora_using_yum

Options:
  -h, --help  Show this help message and finish.
  --dnf       Upgrade using dnf. Warning, this is experimental!
  --yum       Upgrade using yum. [default]

It seems you're running Fedora 19, this script would upgrade your installation to Fedora Rawhide.

2.
Going to upgrade your Fedora to rawhide.
Fedora 20 is currently under development.
And you have chosen to use 'dnf' which is still considered experimental.
Are you really sure?
Hit Enter to continue or Ctrl + C to cancel.

Additional info:
Comment 1 Miroslav Suchý 2013-05-29 07:50:51 EDT
I'm very sorry, but dnf is not ready yet.
I'm testing dnf very often and for example your claim that dnf can upgrade kernel is not true - it can, but it can not preserve X latest kernels as yum can (bug 880524) and distro-sync does not work at all (bug 912165).

I'm watching development of dnf very closely and as soon as it will be ready I will flip to it as it is much much faster.

But for now I have to reject this RFE. And I'm not happy for that. Sorry.

Note You need to log in before you can comment on or make changes to this bug.