Bug 968285 - No keyboard shortcut to quit Boxes
No keyboard shortcut to quit Boxes
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: gnome-boxes (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity low
: rc
: ---
Assigned To: Zeeshan Ali
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-29 07:28 EDT by Vitezslav Humpa
Modified: 2014-06-18 04:55 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-13 09:11:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vitezslav Humpa 2013-05-29 07:28:51 EDT
Description of problem:
Gnome applications provide a consistent window manager independent shortcut to quit them - Ctrl-Q or Ctrl-W. Please consider adding this in Boxes, especially since if not running under gnome-shell the application menu items are unavailable. I realize this can conflict with in-VM shortcuts etc., so this could be configurable similarly as i.e. of Vinagre.

Version-Release number of selected component (if applicable):
gnome-boxes-3.8.1.2-1.el7.x86_64
Comment 1 Zeeshan Ali 2013-07-22 13:08:46 EDT
(In reply to Vitezslav Humpa from comment #0)
> Description of problem:
> Gnome applications provide a consistent window manager independent shortcut
> to quit them - Ctrl-Q or Ctrl-W.

Ctrl-Q doesn't work for you? It really should.
Comment 2 Matthias Clasen 2013-07-30 10:47:28 EDT
Ctrl-Q works here with gnome-boxes 3.8.3
Comment 3 Vitezslav Humpa 2013-07-31 07:28:08 EDT
Tried again with 3.8.3 and Ctrl-Q still doesn't seem to do anything. Confirmed also with a colleague. Build is: gnome-boxes-3.8.3-1.el7.x86_64
Comment 4 Zeeshan Ali 2013-09-04 09:12:54 EDT
Apparently the event handlers for Ctrl+Q and Alt+A were not reliable. I have fixed this in upstream and fix is included in 3.9.91 release.
Comment 8 Ludek Smid 2014-06-13 09:11:43 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.