Bug 968314 - after upgrade with fedup from F17 to F18 touchpad stops working
after upgrade with fedup from F17 to F18 touchpad stops working
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-synaptics (Show other bugs)
rawhide
Unspecified Linux
unspecified Severity medium
: ---
: ---
Assigned To: Peter Hutterer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-29 08:55 EDT by Rui Gouveia
Modified: 2016-01-04 00:10 EST (History)
4 users (show)

See Also:
Fixed In Version: xorg-x11-drv-synaptics-1.6.4-2.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-12 22:02:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rui Gouveia 2013-05-29 08:55:16 EDT
(Maybe this bug belongs to component fedup)


Description of problem:

After upgrade with fedup from F17 to F18 touchpad stops working.


Version-Release number of selected component (if applicable):

fedup last version in F17
May 29 13:22:15 Erased: xorg-x11-drv-synaptics-1.6.3-4.fc17.x86_64
May 29 13:23:47 Installed: xorg-x11-drv-synaptics-1.6.3-3.fc18.x86_64


How reproducible:

I only did the process once, but it was reported in different hardware by another user.


Steps to Reproduce:
1. Upgrade F17 with fedup to F18.
2. Check the xorg-x11-drv-synaptics package release.
3. Check that the touchpad is dead.

Actual results:

Touchpad not working.


Expected results:

Touchpad working.


Additional info:

I fixed the issue removing the F17 package, and installing the F18 one. After a reboot touchpad went back to normal.

# yum remove xorg-x11-drv-synaptics
# yum install xorg-x11-drv-synaptics
Comment 1 Jim Moore 2013-06-15 11:41:31 EDT
Had the identical experience.  Fixed with 'yum distro-sync xorg-x11-drv-synaptics.'  After Xorg logout, touchpad detected and working correctly.
Comment 2 Fedora Update System 2013-06-26 01:33:48 EDT
xorg-x11-drv-synaptics-1.6.4-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/xorg-x11-drv-synaptics-1.6.4-2.fc18
Comment 3 Rui Gouveia 2013-06-26 05:42:08 EDT
Hi,

The problem *WAS NOT* with the package itself. Removing the F17 package and installing the F18 one does fix this issue. Or, simply running "yum dist-sync".

I opened this bug because I think fedup should do this "out-of-the-box". It's a standard package.


Thank you
Rui
Comment 4 Peter Hutterer 2013-06-26 16:32:14 EDT
the upgrade path was broken, with the F17 package > the F18 package. This is why you had to distro-sync. as I wrote in the udpate, the new package doesn't have any code changes, it merely updates the package version.
Comment 5 Fedora Update System 2013-06-26 21:56:40 EDT
Package xorg-x11-drv-synaptics-1.6.4-2.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing xorg-x11-drv-synaptics-1.6.4-2.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-11757/xorg-x11-drv-synaptics-1.6.4-2.fc18
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2013-07-12 22:02:01 EDT
xorg-x11-drv-synaptics-1.6.4-2.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.