Bug 968340 - Perl app try to load module from wrong place
Perl app try to load module from wrong place
Status: CLOSED CURRENTRELEASE
Product: OpenShift Online
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Jhon Honce
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-29 09:32 EDT by Meng Bo
Modified: 2015-05-14 19:20 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-11 00:13:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Meng Bo 2013-05-29 09:32:57 EDT
Description of problem:
Create perl app, and check the error_log for the app.

Found:
[Wed May 29 08:52:42 2013] [error] (2)No such file or directory: mod_mime_magic: can't read magic file /var/lib/openshift/51a5fa045ec49a0916000002/perl/configuration/magic

Since the magic module placed under 
/var/lib/openshift/51a5fa045ec49a0916000002/perl/etc/magic

And there is not a perl/configuration dir.

Version-Release number of selected component (if applicable):
devenv_3283

How reproducible:
always

Steps to Reproduce:
1.Create perl app
2.Check the error_log
3.

Actual results:
Following error appears in the log:
[Wed May 29 08:52:42 2013] [error] (2)No such file or directory: mod_mime_magic: can't read magic file /var/lib/openshift/51a5fa045ec49a0916000002/perl/configuration/magic

Expected results:
Should load the magic module from correct place.

Additional info:
Comment 1 Jhon Honce 2013-05-29 13:26:40 EDT
Fixed in https://github.com/openshift/origin-server/pull/2674
Comment 2 openshift-github-bot 2013-05-29 16:18:09 EDT
Commit pushed to master at https://github.com/openshift/origin-server

https://github.com/openshift/origin-server/commit/703c5c3db14eebcd54b3fbd73a03e910b0660e70
Bug 968340 - Update MIMEMagicFile in conf files
Comment 3 Meng Bo 2013-05-30 03:13:11 EDT
Checked on devenv_3288,

No such errors in perl error log.

Move bug to verified.

Note You need to log in before you can comment on or make changes to this bug.