Bug 968398 - SELinux is preventing /usr/sbin/pppd from 'read, write' accesses on the file pppd2.tdb
SELinux is preventing /usr/sbin/pppd from 'read, write' accesses on the file ...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ppp (Show other bugs)
6.4
All Linux
medium Severity medium
: rc
: ---
Assigned To: Michal Sekletar
Jaroslav Aster
: EasyFix, Patch
Depends On:
Blocks: 1075802
  Show dependency treegraph
 
Reported: 2013-05-29 12:14 EDT by Robert Scheck
Modified: 2015-03-16 04:13 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-03-16 04:13:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Scheck 2013-05-29 12:14:32 EDT
Description of problem:
Configure 3G without NetworkManager stuff, thus classical networking, and try
to do a "service network restart". It will not bring up the ppp0 interface of
3G but cause this SELinux message:

type=AVC msg=audit(1369839157.521:192552): avc:  denied  { read write } for  pid=2498 comm="pppd" name="pppd2.tdb" dev=sda2 ino=10488093 scontext=unconfined_u:system_r:pppd_t:s0 tcontext=unconfined_u:object_r:var_run_t:s0 tclass=file
type=SYSCALL msg=audit(1369839157.521:192552): arch=x86_64 syscall=open success=no exit=EACCES a0=7f56b24e3d2f a1=42 a2=1a4 a3=0 items=0 ppid=2496 pid=2498 auid=0 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=15156 comm=pppd exe=/usr/sbin/pppd subj=unconfined_u:system_r:pppd_t:s0 key=(null)

Version-Release number of selected component (if applicable):
ppp-2.4.5-5.el6.x86_64

How reproducible:
Everytime, see above and below.

Actual results:
SELinux is preventing /usr/sbin/pppd from 'read, write' accesses on the file 
pppd2.tdb

Expected results:
No issues, no AVC denied.

Additional info:
http://pkgs.fedoraproject.org/cgit/ppp.git/plain/ppp-2.4.5-var_run_ppp.patch 
applying solves the issue.

This issue was already resolved for Fedora with Red Hat Bugzilla #560014.
Comment 1 Robert Scheck 2013-05-29 12:15:26 EDT
Note that a manual "ifup ppp0" of course works due to different context!
Comment 2 Robert Scheck 2013-05-29 16:45:12 EDT
Cross-filed case 00881225 in the Red Hat customer portal.
Comment 4 Michal Sekletar 2013-06-29 11:22:07 EDT
Thank you for the report. Unfortunately, ppp package is not going to be updated in the next maintenance release of Red Hat Enterprise Linux. Due to the update policy I am unable to address this issue right now. This bug maybe addressed in some future release of RHEL.
Comment 5 Robert Scheck 2013-06-29 13:54:36 EDT
I really dislike to read this, escalating case 00881225.
Comment 6 Michal Sekletar 2013-06-29 15:19:15 EDT
If fixing of this bug is really important for you escalation of the support case is IMHO the best way to get the fix. Thanks for your understanding and cooperation.
Comment 10 Michal Sekletar 2014-07-29 09:46:18 EDT
I have no problem with merging patch. I'll try to get this in for RHEL-6.7. This also needs PM and QA review tough.
Comment 17 errata-xmlrpc 2015-03-16 04:13:52 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0685.html

Note You need to log in before you can comment on or make changes to this bug.