Bug 968430 - VNC console does not capture/send CTRL to instance.
VNC console does not capture/send CTRL to instance.
Status: CLOSED CURRENTRELEASE
Product: Red Hat OpenStack
Classification: Red Hat
Component: novnc (Show other bugs)
3.0
Unspecified Unspecified
unspecified Severity unspecified
: async
: 4.0
Assigned To: Nikola Dipanov
Ami Jeain
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-29 13:29 EDT by Stephen Gordon
Modified: 2016-04-26 16:11 EDT (History)
3 users (show)

See Also:
Fixed In Version: novnc-0.4-8.el6ost.noarch
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-06 14:42:48 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen Gordon 2013-05-29 13:29:25 EDT
Description of problem:

I ran up a Cirros instance and when I try and CTRL+C a command run within it only the C makes it to the guest (gets printed to screen, running command does not terminate). Browser is Chrome 27, I do not have any defined additional key capturing *that I am aware of*.

novnc-0.4-4.el6ost.noarch
openstack-nova-novncproxy-0.4-4.el6ost.noarch
openstack-dashboard-2013.1.1-2.el6ost.noarch
Comment 1 Nikola Dipanov 2014-01-06 14:42:48 EST
novnc-0.4-8.el6ost.noarch
openstack-nova-novncproxy-2013.2.1-1.el6ost.noarch

CTRL+C seems to be working both in Horizon and using the direct url (as presented by get-vnc-console)

I was using Firefox 24 on Fedora 19 to test this

I urge the reporter to confirm that the bug is gone from the latest release with Chrome as well, and if that is the case possibly re-open the bug.

Note You need to log in before you can comment on or make changes to this bug.