Bug 968589 - [abrt] apper-0.8.0-0.11.20121126git.fc18: _int_malloc: Process /usr/bin/apper was killed by signal 11 (SIGSEGV)
[abrt] apper-0.8.0-0.11.20121126git.fc18: _int_malloc: Process /usr/bin/apper...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: apper (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
abrt_hash:41599f378b289316285689a6838...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-29 18:28 EDT by jradick
Modified: 2014-02-05 16:35 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-05 16:35:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jradick 2013-05-29 18:28:50 EDT
Description of problem:
After a fresh install into a 64-bit virtual machine (on an early 2011 MacBook Pro running OS X 10.8.3, using VMware Fusion 5.0.3), I tried to use the software installer to select a reasonable set of developer friendly tools.  After several attempts to "apply" the selected changes which failed due to dependency problems that I couldn't figure out how to resolve, the installer crashed.

I'm really annoyed at how non-intuitive it is to get a developer-friendly system installed.  It used to be pretty easy but all the Linux distros I've tried in the past few years seem to be making this more and more of a colossal pain.

Version-Release number of selected component:
apper-0.8.0-0.11.20121126git.fc18

Additional info:
backtrace_rating: 4
cmdline:        /usr/bin/apper
crash_function: _int_malloc
executable:     /usr/bin/apper
kernel:         3.6.10-4.fc18.x86_64
uid:            0
xsession_errors: apper(1713) ApperKCM::search: Search type not defined yet 

Truncated backtrace:
Thread no. 1 (10 frames)
 #1 malloc at /lib64/libc.so.6
 #2 QRegExpMatchState::prepareForMatch(QRegExpEngine*) at /lib64/libQtCore.so.4
 #3 QRegExp::operator=(QRegExp const&) at /lib64/libQtCore.so.4
 #4 KuitSemanticsPrivate::finalizeVisualText(QString const&, Kuit::Fmt::Var, bool, bool) const at /lib64/libkdecore.so.5
 #5 KuitSemanticsPrivate::format(QString const&, QString const&) const at /lib64/libkdecore.so.5
 #6 KuitSemantics::format(QString const&, QString const&) const at /lib64/libkdecore.so.5
 #7 KLocalizedStringPrivate::postFormat(QString const&, QString const&, QString const&) const at /lib64/libkdecore.so.5
 #8 KLocalizedStringPrivate::toString(KLocale const*, QString const*) const at /lib64/libkdecore.so.5
 #9 KLocalizedString::toString() const at /lib64/libkdecore.so.5
 #10 PackageModel::data(QModelIndex const&, int) const at /usr/lib64/apper/libapper.so
Comment 1 Fedora End Of Life 2013-12-21 08:46:49 EST
This message is a reminder that Fedora 18 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 18. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '18'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 18's end of life.

Thank you for reporting this issue and we are sorry that we may not be 
able to fix it before Fedora 18 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior to Fedora 18's end of life.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 2 Fedora End Of Life 2014-02-05 16:35:27 EST
Fedora 18 changed to end-of-life (EOL) status on 2014-01-14. Fedora 18 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.