Bug 968729 - Search logic with AND returns OR results
Search logic with AND returns OR results
Status: CLOSED CURRENTRELEASE
Product: PressGang CCMS
Classification: Community
Component: Web-UI (Show other bugs)
1.1
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 1.3
Assigned To: Lee Newson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-29 20:27 EDT by mmurray
Modified: 2013-12-03 17:16 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-03 17:16:14 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description mmurray 2013-05-29 20:27:44 EDT
Description of problem:
Search with AND internal logic returns results for OR internal logic.

Version-Release number of selected component (if applicable):
Build 201305221423

How reproducible:


Steps to Reproduce:
1. Click 'Search'
2. Select a tag group, e.g. JBDS
3. Select 'Book' tag
4. Include 3 JBDS book tags in search, so have '+' symbol: Installation Guide, Migration guide, Getting Started Guide
5. Change internal logic to AND
6. Click 'search topics' button

Actual results:
Get *all* topics that are in any of the three books (OR logic)

Expected results:
Get topics that are *common* in all three books (AND logic)

Additional info:
Comment 1 Lee Newson 2013-05-29 21:07:19 EDT
The problem is that the new UI doesn't replicate the old UI. When setting the "catint" query parameter the category id and project should be set like so "catint6-24" for Category 6 (Book) and Project 24 (JBDS). If no project is set, as it currently does so, then it assumes that the Project is the Common Project grouping.

So we either fix this in the GUI or change the backend to not require the Project. The problem with the latter option is that the "and/or" searching wouldn't be specific to the Project grouping, and would be done on a global scope. I believe that was the reasoning when it was done in the old UI anyways.
Comment 2 Lee Newson 2013-11-07 23:43:35 EST
Fixed in 1.3-SNAPSHOT build 201311081438

The query generation mechanism will now include the project id in the query url generated, as it used to in the old SEAM UI.
Comment 3 Lee Newson 2013-11-07 23:56:31 EST
Note: This version is currently live on the development/test server.
Comment 4 Matthew Casperson 2013-11-24 19:20:52 EST
Confirmed that the AND logic works as expected.

Note You need to log in before you can comment on or make changes to this bug.