Bug 968863 - RFE: Enable remarks to show up in docbuilder output
RFE: Enable remarks to show up in docbuilder output
Status: CLOSED NOTABUG
Product: PressGang CCMS
Classification: Community
Component: DocBook-builder (Show other bugs)
3.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: pressgang-ccms-dev
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-30 03:13 EDT by lcarlon
Modified: 2013-05-30 22:20 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-30 21:08:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description lcarlon 2013-05-30 03:13:43 EDT
Description of problem:

I'd like to be able to included highlighted remarks in docbuilder output by including show_remarks = 1 in content spec files, and <remark>This is a remark</remark> in a topic.
Comment 1 Stephen Gordon 2013-05-30 10:01:09 EDT
Lee, does this not work if you include the show_remarks: 1 in the publican.cfg section of the spec file?
Comment 2 Lee Newson 2013-05-30 18:44:30 EDT
Yeah what Steve said would work. The reason we never added it as a metadata property was to try and make it more difficult to include in a final build and ideally when you wanted a build with remarks enabled, you'd build with the "--show-remarks" option. So perhaps the docbuilder should be configured to use that option as well when building?

Otherwise I really don't see any issue with adding it as a metadata field. In saying that though, it'd be something more along the lines of "Show Remarks = ON" or "Remarks = ON" just to keep with consistency.
Comment 3 lcarlon 2013-05-30 21:08:38 EDT
Thanks Steve, Thanks Lee.

No it's fine as it is. I didn't realize we need to add it to the publican.cfg.

Closing the bug to save you the trouble of doing.

Lee
Comment 4 Stephen Gordon 2013-05-30 22:20:17 EDT
(In reply to Lee Newson from comment #2)
> ...you'd build with the "--show-remarks" option. So perhaps the docbuilder should be configured to use that option as well when building?

To be honest that actually seems like a pretty reasonable idea.

Note You need to log in before you can comment on or make changes to this bug.