Bug 968864 - repo and product status are broken after repo synchronization
repo and product status are broken after repo synchronization
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management (Show other bugs)
Nightly
Unspecified Unspecified
unspecified Severity high (vote)
: Unspecified
: --
Assigned To: Petr Chalupa
Garik Khachikyan
: Triaged
: 968959 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-30 03:19 EDT by Ales Dujicek
Modified: 2015-05-04 21:30 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-18 17:20:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ales Dujicek 2013-05-30 03:19:55 EDT
Description of problem:

After repo synchronization, you can check repo and product status

repo synchronize --name repo --product product --org org1
Repo [ repo ] synchronized 

katello> repo status --name repo --product product --org org1
--------------------------------------------------------------------------------
                               Repository Status
--------------------------------------------------------------------------------

Package Count : 32
Last Sync     : 2013/05/30 02:27:35
Last Errors:
    

katello> product status --name product --org org1
--------------------------------------------------------------------------------
                                 Product Status
--------------------------------------------------------------------------------

ID            : 1369895241183
Name          : product
Provider ID   : 3
Provider Name : provider
Last Sync     : 2013/05/30 02:27:35
Sync State    : Finished



But after a few seconds you get different output

katello> repo status --name repo --product product --org org1
--------------------------------------------------------------------------------
                               Repository Status
--------------------------------------------------------------------------------

Package Count : 32
Last Sync     : 2013/05/30 02:27:35
Progress      : 0% done (0 of 0 packages downloaded)
Last Errors:
    

katello> product status --name product --org org1
--------------------------------------------------------------------------------
                                 Product Status
--------------------------------------------------------------------------------

ID            : 1369895241183
Name          : product
Provider ID   : 3
Provider Name : provider
Last Sync     : 2013/05/30 02:27:35
error: u'success' (more in the log file /var/log/katello/client.log)


Version-Release number of selected component (if applicable):
katello-glue-candlepin-1.4.2-1.git.478.8271f2c.el6.noarch
katello-glue-pulp-1.4.2-1.git.478.8271f2c.el6.noarch
signo-katello-0.0.9-1.el6.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-cli-1.4.2-1.git.71.2a2d883.el6.noarch
katello-qpid-broker-key-pair-1.0-1.noarch
katello-repos-1.4.2-1.el6.noarch
katello-cli-common-1.4.2-1.git.71.2a2d883.el6.noarch
katello-certs-tools-1.4.2-1.el6.noarch
katello-configure-1.4.3-1.git.41.e1043b5.el6.noarch
katello-common-1.4.2-1.git.478.8271f2c.el6.noarch
katello-all-1.4.2-1.git.478.8271f2c.el6.noarch
katello-qpid-client-key-pair-1.0-1.noarch
katello-glue-elasticsearch-1.4.2-1.git.478.8271f2c.el6.noarch
katello-selinux-1.4.3-1.git.3.ce8227b.el6.noarch
katello-1.4.2-1.git.478.8271f2c.el6.noarch


How reproducible:
always

Steps to Reproduce:
1. create org, provider, etc.
org create --name org1
provider create --name provider --org org1
product create --name product --org org1 --provider provider
repo create --org org1 --product product --url http://inecas.fedorapeople.org/fakerepos/zoo3/ --name repo
2. synchronize repo
repo synchronize --name repo --product product --org org1
3. check status, wait a while and check it again
repo status --name repo --product product --org org1
product status --name product --org org1
Comment 1 Mike McCune 2013-06-03 13:30:48 EDT
*** Bug 968959 has been marked as a duplicate of this bug. ***
Comment 3 Petr Chalupa 2013-06-11 07:06:02 EDT
I've tried on zoo3 repo and some others. I was not able to reproduce. Moving to QA to verify.
Comment 4 Garik Khachikyan 2013-06-11 07:40:23 EDT
# VERIFIED

doing status for both repo and product for custom repos (as stated in this bug) - fixed.
For Red Hat repos there are some issues already reported as bugs.

checked against version:
---
candlepin-0.8.9-1.el6_4.noarch
candlepin-cert-consumer-ibm-ls22-01.rhts.eng.brq.redhat.com-1.0-1.noarch
candlepin-scl-1-5.el6_4.noarch
candlepin-scl-quartz-2.1.5-5.el6_4.noarch
candlepin-scl-rhino-1.7R3-1.el6_4.noarch
candlepin-scl-runtime-1-5.el6_4.noarch
candlepin-selinux-0.8.9-1.el6_4.noarch
candlepin-tomcat6-0.8.9-1.el6_4.noarch
elasticsearch-0.19.9-8.el6sat.noarch
katello-1.4.2-11.el6sat.noarch
katello-agent-1.4.3-1.git.1.24fe511.el6.noarch
katello-all-1.4.2-11.el6sat.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-certs-tools-1.4.2-2.el6sat.noarch
katello-cli-1.4.2-7.el6sat.noarch
katello-cli-common-1.4.2-7.el6sat.noarch
katello-common-1.4.2-11.el6sat.noarch
katello-configure-1.4.3-14.el6sat.noarch
katello-configure-foreman-1.4.3-14.el6sat.noarch
katello-foreman-all-1.4.2-11.el6sat.noarch
katello-glue-candlepin-1.4.2-11.el6sat.noarch
katello-glue-elasticsearch-1.4.2-11.el6sat.noarch
katello-glue-pulp-1.4.2-11.el6sat.noarch
katello-qpid-broker-key-pair-1.0-1.noarch
katello-qpid-client-key-pair-1.0-1.noarch
katello-selinux-1.4.3-3.el6sat.noarch
m2crypto-0.21.1.pulp-8.el6sat.x86_64
mod_wsgi-3.4-1.pulp.el6sat.x86_64
pulp-rpm-handlers-2.1.1-1.el6sat.noarch
pulp-rpm-plugins-2.1.1-1.el6sat.noarch
pulp-selinux-2.1.1-1.el6sat.noarch
pulp-server-2.1.1-1.el6sat.noarch
python-isodate-0.5.0-1.pulp.el6sat.noarch
python-oauth2-1.5.170-3.pulp.el6sat.noarch
python-pulp-agent-lib-2.1.1-1.el6sat.noarch
python-pulp-common-2.1.1-1.el6sat.noarch
python-pulp-rpm-common-2.1.1-1.el6sat.noarch
python-qpid-0.18-5.el6_4.noarch
python-rhsm-1.8.0-1.pulp.el6sat.x86_64
qpid-cpp-client-0.14-22.el6_3.x86_64
qpid-cpp-client-ssl-0.14-22.el6_3.x86_64
qpid-cpp-server-0.14-22.el6_3.x86_64
qpid-cpp-server-ssl-0.14-22.el6_3.x86_64
ruby193-rubygem-foreman-katello-engine-0.0.8-5.el6sat.noarch
ruby193-rubygem-katello-foreman-engine-0.0.3-4.el6sat.noarch
ruby193-rubygem-katello_api-0.0.3-2.el6_4.noarch
ruby193-rubygem-ldap_fluff-0.2.2-1.el6sat.noarch
signo-katello-0.0.16-1.el6sat.noarch
Comment 6 Mike McCune 2013-07-18 17:20:32 EDT
mass move to CLOSED:CURRENTRELEASE since MDP1 has been released.

Note You need to log in before you can comment on or make changes to this bug.