Bug 968879 - Log enhancements for issues related to bug: 968870
Log enhancements for issues related to bug: 968870
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterfs (Show other bugs)
2.0
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: Pranith Kumar K
Sachidananda Urs
:
Depends On: 928784 973922 985738
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-30 03:50 EDT by Sachidananda Urs
Modified: 2013-09-23 18:35 EDT (History)
3 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0.15rhs
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-23 18:35:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sachidananda Urs 2013-05-30 03:50:24 EDT
Description of problem:

In the scenario when one of the nodes goes down when the load on client is high any of the below issues are noticed:

1) symlinks get zeroed out and become regular files
2) some of the files become zero byte
3) spurious split-brains are observed

But the files related to case 1 and case 2 are not reported in any of the logs. It is absolutely clueless what happened on the files or what was happening.

Logs need enhancements to verify things.
Comment 3 Sachidananda Urs 2013-08-13 02:01:29 EDT
Verified on glusterfs 3.4.0.18rhs built on Aug  7 2013 08:02:45

Now the logs look better and I see the logs with information printed on Comment 2
Comment 4 Sachidananda Urs 2013-08-13 02:01:50 EDT
Verified on glusterfs 3.4.0.18rhs built on Aug  7 2013 08:02:45

Now the logs look better and I see the logs with information printed on Comment
Comment 5 Scott Haines 2013-09-23 18:35:37 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.