Bug 968882 - Ruby1.8 ruby 1.9 and python 2.6 apps try to load module from wrong places
Ruby1.8 ruby 1.9 and python 2.6 apps try to load module from wrong places
Status: CLOSED CURRENTRELEASE
Product: OpenShift Online
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Jhon Honce
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-30 04:10 EDT by Meng Bo
Modified: 2015-05-14 19:20 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-11 00:13:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Meng Bo 2013-05-30 04:10:08 EDT
Description of problem:
Create ruby1.8 ruby 1.9 and python 2.6 app, and check the error_log for the apps.

Found:
./c3f5fc06c8fa11e280dd22000a9a810c/python/logs/error_log-20130530-000000-EST:[Thu May 30 03:30:37 2013] [error] (2)No such file or directory: mod_mime_magic: can't read magic file /var/lib/openshift/c3f5fc06c8fa11e280dd22000a9a810c/python/configuration/magic


Since the magic module placed under 
/var/lib/openshift/**/**/etc/magic


Version-Release number of selected component (if applicable):
devenv_3288

How reproducible:
always

Steps to Reproduce:
1.Create ruby1.8/ruby1.9/python2.6 app
2.Check the error_log
3.

Actual results:
Following error appears in the log:

./c3f5fc06c8fa11e280dd22000a9a810c/python/logs/error_log-20130530-000000-EST:[Thu May 30 03:30:37 2013] [error] (2)No such file or directory: mod_mime_magic: can't read magic file /var/lib/openshift/c3f5fc06c8fa11e280dd22000a9a810c/python/configuration/magic
./c3f5fc06c8fa11e280dd22000a9a810c/python/logs/error_log-20130530-000000-EST:[Thu May 30 03:30:37 2013] [error] (2)No such file or directory: mod_mime_magic: can't read magic file /var/lib/openshift/c3f5fc06c8fa11e280dd22000a9a810c/python/configuration/magic
./51a700f513df2f0885000003/ruby/logs/error_log-20130530-000000-EST:[Thu May 30 03:34:34 2013] [error] (2)No such file or directory: mod_mime_magic: can't read magic file /var/lib/openshift/51a700f513df2f0885000003/ruby/configuration/magic
./51a700f513df2f0885000003/ruby/logs/error_log-20130530-000000-EST:[Thu May 30 03:34:34 2013] [error] (2)No such file or directory: mod_mime_magic: can't read magic file /var/lib/openshift/51a700f513df2f0885000003/ruby/configuration/magic
./51a700c213df2f0885000002/ruby/logs/error_log-20130530-000000-EST:[Thu May 30 03:33:46 2013] [error] (2)No such file or directory: mod_mime_magic: can't read magic file /var/lib/openshift/51a700c213df2f0885000002/ruby/configuration/magic
./51a700c213df2f0885000002/ruby/logs/error_log-20130530-000000-EST:[Thu May 30 03:33:46 2013] [error] (2)No such file or directory: mod_mime_magic: can't read magic file /var/lib/openshift/51a700c213df2f0885000002/ruby/configuration/magic


Expected results:
Should load the magic module from correct place.

Additional info:
The issue is related to Bug 968340
Comment 1 Jhon Honce 2013-05-30 12:55:20 EDT
Fix https://github.com/openshift/origin-server/pull/2696
Comment 2 openshift-github-bot 2013-05-30 16:54:28 EDT
Commit pushed to master at https://github.com/openshift/origin-server

https://github.com/openshift/origin-server/commit/77ea16afbeda57837653c5db4b0e1b14072288c5
Bug 968882 - Fix MIMEMagicFile

* httpd*conf files did not match where magic file was located
Comment 3 Meng Bo 2013-05-31 01:34:37 EDT
Checked on devenv_3296, issue fixed.

No errors appear in the error_log and the httpd*.conf point to the right directory.

Note You need to log in before you can comment on or make changes to this bug.