Bug 968939 - jboss-errai-kitchensink-archetype fails to build with openjdk7
jboss-errai-kitchensink-archetype fails to build with openjdk7
Status: CLOSED WORKSFORME
Product: JBoss Enterprise WFK Platform 2
Classification: JBoss
Component: Errai, Examples (Show other bugs)
2.3.0
Unspecified Unspecified
unspecified Severity medium
: GA
: 2.3.0
Assigned To: Jonathan Fuerth
Matous Jobanek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-30 06:19 EDT by Marek Schmidt
Modified: 2013-07-01 12:41 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
java version "1.7.0_19" OpenJDK Runtime Environment (fedora-2.3.9.5.fc18-x86_64) OpenJDK 64-Bit Server VM (build 23.7-b01, mixed mode)
Last Closed: 2013-07-01 12:41:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marek Schmidt 2013-05-30 06:19:19 EDT
Description of problem:

A project generated by the jboss-errai-kitchensink-archetype fails to build on OpenJDK7, while it builds on both oracle JDK 1.6 and JDK7

Version-Release number of selected component (if applicable):
org.jboss.errai.archetypes:jboss-errai-kitchensink-archetype:2.2.1.Final


...
[INFO]          Rebinding org.jboss.errai.marshalling.client.api.MarshallerFactory
[INFO]             Invoking generator org.jboss.errai.marshalling.rebind.MarshallersGenerator
[INFO]                Generating Marshallers Bootstrapper...
[INFO]    Scanning for additional dependencies: /home/maschmid/workspace-7.0.0.Beta1/errai-kitchensink/target/.generated/org/example/errai_kitchensink/client/shared/_MemberValidator.java
[INFO]       Adding '1' new generated units
[INFO]          Validating newly compiled units
[INFO]             Ignored 1 unit with compilation errors in first pass.
[INFO] Compile with -strict or with -logLevel set to TRACE or DEBUG to see all errors.
[INFO]    [ERROR] Errors in '/home/maschmid/workspace-7.0.0.Beta1/errai-kitchensink/target/.generated/org/example/errai_kitchensink/client/shared/_MemberValidatorImpl.java'
[INFO]       [ERROR] Line 431:  The method validate(GwtValidationContext<T>, Set<ConstraintViolation<T>>, Member, V, ConstraintValidator<A,? super V>, ConstraintDescriptorImpl<A>, Class<?>[]) in the type AbstractG
wtSpecificValidator<Member> is not applicable for the arguments (GwtValidationContext<T>, Set<ConstraintViolation<T>>, Member, String, SizeValidatorForMap, ConstraintDescriptorImpl<Size>, Class<?>[])
[INFO]       [ERROR] Line 451:  The method validate(GwtValidationContext<T>, Set<ConstraintViolation<T>>, Member, V, ConstraintValidator<A,? super V>, ConstraintDescriptorImpl<A>, Class<?>[]) in the type AbstractG
wtSpecificValidator<Member> is not applicable for the arguments (GwtValidationContext<T>, Set<ConstraintViolation<T>>, Member, String, SizeValidatorForMap, ConstraintDescriptorImpl<Size>, Class<?>[])
[INFO]       [ERROR] Line 476:  The method validate(GwtValidationContext<T>, Set<ConstraintViolation<T>>, Member, V, ConstraintValidator<A,? super V>, ConstraintDescriptorImpl<A>, Class<?>[]) in the type AbstractG
wtSpecificValidator<Member> is not applicable for the arguments (GwtValidationContext<T>, Set<ConstraintViolation<T>>, Member, String, SizeValidatorForMap, ConstraintDescriptorImpl<Size>, Class<?>[])
[INFO]    [ERROR] Cannot proceed due to previous errors
Comment 1 Jonathan Fuerth 2013-06-24 11:51:49 EDT
This appears to be a duplicate of bug 921049, which was related to Errai 2.2 and GWT 2.4. Reading the comments there, I see that building under OpenJDK 1.7.0_09 did succeed with Errai 2.2 and GWT 2.5.1.

Are you sure your build is using GWT 2.5.1? That should be the correct GWT version to use with Errai 2.3.x.
Comment 2 Jonathan Fuerth 2013-06-26 12:11:57 EDT
I've just published a new kitchensink archetype: version 2.3.2.Final. This one should be pointing to Errai 2.3.2.Final-redhat-1 when you invoke it with -Denterprise=true. You should find that this problem goes away when you do so (due to the update to GWT 2.5.1)
Comment 3 Matous Jobanek 2013-07-01 12:41:13 EDT
I cannot reproduce the bug.
My environment:
java version "1.7.0_25"
OpenJDK Runtime Environment (fedora-2.3.10.3.fc18-x86_64)
OpenJDK 64-Bit Server VM (build 23.7-b01, mixed mode)

Note You need to log in before you can comment on or make changes to this bug.