Bug 968965 - quantum-metadata-agent is not run with the configuration file /usr/share/quantum/quantum-dist.conf
quantum-metadata-agent is not run with the configuration file /usr/share/quan...
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-quantum (Show other bugs)
3.0
Unspecified Unspecified
unspecified Severity unspecified
: snapshot2
: 3.0
Assigned To: Gary Kotton
yfried
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-30 07:32 EDT by Gary Kotton
Modified: 2016-04-26 09:59 EDT (History)
4 users (show)

See Also:
Fixed In Version: openstack-quantum-2013.1.1-9.el6ost
Doc Type: Bug Fix
Doc Text:
The initialization script for the OpenStack Networking metadata service was starting the service with arguments that did not include distribution specific configuration file /usr/share/quantum/quantum-dist.conf. As a result the service was previously being started with incorrect default configuration values set. The initialization script has been updated and now starts the metadata service with arguments that include the distribution specific configuration file.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-11 14:56:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gary Kotton 2013-05-30 07:32:10 EDT
Description of problem:

[root@dhcp-4-126 ~(keystone_admin)]# ps aux |grep quan
quantum   2966  0.7  0.3 295276 31784 ?        S    07:03   0:09 python /usr/bin/quantum-l3-agent --log-file /var/log/quantum/l3-agent.log --config-file /usr/share/quantum/quantum-dist.conf --config-file /etc/quantum/quantum.conf --config-file /etc/quantum/l3_agent.ini
quantum   2980  0.0  0.3 261468 26576 ?        S    07:03   0:00 python /usr/bin/quantum-metadata-agent --log-file /var/log/quantum/metadata-agent.log --config-file /etc/quantum/quantum.conf --config-file /etc/quantum/metadata_agent.ini

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Gary Kotton 2013-05-30 07:36:21 EDT
diff --git a/quantum-metadata-agent.init b/quantum-metadata-agent.init
index e6f146f..f930e19 100644
--- a/quantum-metadata-agent.init
+++ b/quantum-metadata-agent.init
@@ -23,7 +23,7 @@ start() {
     [ -x $exec ] || exit 5
     [ -f $config ] || exit 6
     echo -n $"Starting $prog: "
-    daemon --user quantum --pidfile $pidfile "$exec --log-file /var/log/$proj/$plugin.log --config-file /etc/$proj/$proj.conf --config-file $config &>/dev/null & echo \$! > $pidfile"
+    daemon --user quantum --pidfile $pidfile "$exec --log-file /var/log/$proj/$plugin.log --config-file /usr/share/$proj/$proj-dist.conf --config-file /etc/$proj/$proj.conf --config-file $config &>/dev/null & echo \$! > $pi
     retval=$?
     echo
     [ $retval -eq 0 ] && touch $lockfile
Comment 2 Gary Kotton 2013-05-30 07:37:44 EDT
diff --git a/quantum-metadata-agent.init b/quantum-metadata-agent.init
index e6f146f..f930e19 100644
--- a/quantum-metadata-agent.init
+++ b/quantum-metadata-agent.init
@@ -23,7 +23,7 @@ start() {
     [ -x $exec ] || exit 5
     [ -f $config ] || exit 6
     echo -n $"Starting $prog: "
-    daemon --user quantum --pidfile $pidfile "$exec --log-file /var/log/$proj/$plugin.log --config-file /etc/$proj/$proj.conf --config-file $config &>/dev/null & echo \$! > $pidfile"
+    daemon --user quantum --pidfile $pidfile "$exec --log-file /var/log/$proj/$plugin.log --config-file /usr/share/$proj/$proj-dist.conf --config-file /etc/$proj/$proj.conf --config-file $config &>/dev/null & echo \$! > $pidfile"
     retval=$?
     echo
     [ $retval -eq 0 ] && touch $lockfile
diff --git a/quantum-metadata-agent.upstart b/quantum-metadata-agent.upstart
index c11261b..9f51395 100644
--- a/quantum-metadata-agent.upstart
+++ b/quantum-metadata-agent.upstart
@@ -6,4 +6,4 @@ stop on runlevel [S016]
 
 respawn
 
-exec su -s /bin/sh -c "exec /usr/bin/quantum-metadata-agent --config-file /etc/quantum/quantum.conf --config-file /etc/quantum/metadata_agent.ini --log-file /var/log/quantum/metadata-agent.log" quantum
+exec su -s /bin/sh -c "exec /usr/bin/quantum-metadata-agent --config-file /usr/share/quantum/quantum-dist.conf --config-file /etc/quantum/quantum.conf --config-file /etc/quantum/metadata_agent.ini --log-file /var/log/quantum/metadata-agent.log" quantum
Comment 6 Ofer Blaut 2013-06-04 09:10:18 EDT
Hi Gary

Please add more details on what to test 

Ofer
Comment 7 yfried 2013-06-05 01:37:27 EDT
# quantum --version
quantum 2.0

# ps aux | grep quantum
quantum  21994  0.0  0.0 261460 26576 ?        S    Jun03   0:00 python /usr/bin/quantum-metadata-agent --log-file /var/log/quantum/metadata-agent.log --config-file /usr/share/quantum/quantum-dist.conf --config-file /etc/quantum/quantum.conf --config-file /etc/quantum/metadata_agent.ini
Comment 9 errata-xmlrpc 2013-06-11 14:56:50 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0933.html

Note You need to log in before you can comment on or make changes to this bug.